1

I I have a GekkoScience Compac BM1384 bitcoin miner that I am trying to get working with CGMiner on my Raspberry Pi. It is really annoying though, as it doesnt detect any devices on startup. However, when I go into USB management and select I it lists my bitcoin miner and it says "inactive". But when I try to enable it it says "invalid selection'.

Any suggestions? Thanks, BytePhoenix

1

CGMiner doesn't come with support for that particular miner by default. I believe you have to get the driver for it. You can use bfgminer, which from 5.3.0 supports your miner out of the box.

Instructions from https://bitcointalk.org/index.php?topic=1173963.0

The stickminer will enumerate as an antminer U3 on cgminer (if the version of cgminer you're using supports the U3), and should run fine. It may give warnings about "no valid hashes within 3 seconds" but this is fine, as the U3 has a higher hashrate, confusing cgminer but not noticeably affecting performance. If your hardware errors are low you're fine. These older version of cgminer do not allow a clock rate over 250MHz. This is pretty good for most people as that's moderately high power but in theory the chips will run up to 500MHz.

Luke Jr added bfgminer support in bfgminer 5.3.0, so you may use that version of bfgminer.

I (novak) have written a cgminer driver which enumerates the compacs as expected, removes the error, and ramps up the clock slowly to prevent spikes on USB power. My custom cgminer can be found here: source code: gekkoscience.com/misc/cgminer-gekko.tar.gz win32 binary: gekkoscience.com/misc/cgminer-gekko-win32.zip EDIT: The current version supports bitshopper compacs as well, and can be (and is, in the case of windows) compiled with icarus support.

I have not yet tested it but edonkey was nice enough to upload a custom minera image with cgminer-gekko enabled as a custom miner. You can set the frequency under manual options as: --compac-freq 150. Link: https://dbtbmm05cubzd.cloudfront.net/cryptocurrency/mods/minera_compac_mod.zip

On the engineering sample sticks you can only use old cgminer as the newer drivers for both cgminer and bfgminer depend on a hexfile flashed to the cp2102 which the engineering samples do not have.

If you need to run cgminer on windows (either stock or mine), you'll need to install the zadig driver. You can find it here: http://ck.kolivas.org/apps/cgminer/zadig/

Run the program and install the winusb driver for the compac(s) that you have plugged into your windows machine. You may need to replug the compacs afterwards while cgminer is running to get them to start mining.

=========

=How to Run=

Old cgminer: To build use --enable-icarus flag.

./cgminer -o stratum+tcp://stratum.mining.eligius.st:3334 -u

1BURGERAXHH6Yi6LRybRJK7ybEm5m5HwTr --au3-freq 150

GekkoScience cgminer: To build use --enable-gekko flag.

./cgminer -o stratum+tcp://stratum.mining.eligius.st:3334 -u

1BURGERAXHH6Yi6LRybRJK7ybEm5m5HwTr --compac-freq 150

bfgminer:

./bfgminer -o stratum+tcp://stratum.mining.eligius.st:3334 -O

1BURGERAXHH6Yi6LRybRJK7ybEm5m5HwTr --set compac:clock=x0b83

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.