1

First I close Bitcoin Core...

The size of Bitcoin Core it is 105GB and I want to do pruning so I can have only 2 GB. I make a notepad file named bitcoin.conf and then I write inside prune=2000 or I even tried prune=<2000>.

Then, I have put this file at the install directory or I created the folder Bitcoin and I have put the notepad file in there at the path C:\Users\<user name>\AppData\Roaming\Bitcoin

After all these I open the Bitcoin Core, but nothing happens, it still is 105 GB.

What I am doing wrong? Please help me, I can't understand!

enter image description here

  • 1
    Where did you place bitcoin.conf file? Can you check your debug.log (should be in the same directory)? Also -prune=2000 will not result in a 2GB datadir-size, more 4GB because the UTXO set and header-index will take up some space too. Lowest possible size is -prune=550. – Jonas Schnelli Jan 6 '17 at 11:55
  • I have uploaded a pic that you can see they are in the same folder and I have opened the notepad file I created to see what I have written inside. What am I doing wrong Jonas? Thx in advance! – Balema Jan 6 '17 at 12:19
  • related: How can I run bitcoind in pruning mode? – Murch Jan 6 '17 at 13:32
  • @JonasSchnelli: Do you know when the pruning would start? Would it be immediately after startup or only e.g. when the next block is added? (See comment on my answer for context.) – Murch Jan 6 '17 at 13:36
  • 1
    Pruning is simple, just add -prune=550 to your startup arguments. If you have already synced and verified the chain, it will immediately (at startup) prune the chain. – Jonas Schnelli Jan 8 '17 at 10:29
1

If you put startup commands on the command line, you need to add a dash in the beginning (e.g. bitcoind -prune=2000).

However, when you put them in the bitcoin.conf, I think they have to be put without a dash (e.g. prune=2000). Yet, in the screenshot you show it has a dash. Have you tried putting it in the bitcoin.conf without the dash?

  • Yes, I have tried it and without dash... What should be happening if the prune command works? I mean the 105GB would disappear instantly? I don't know what to do more so I can prune... if anyone can think something is welcomed! – Balema Jan 6 '17 at 13:28
  • Not sure, sorry. It should at the latest trigger with the next block discovered though. – Murch Jan 6 '17 at 14:03
1

The problem is right there in your screenshot. You have not actually created the bitcoin.conf. It should not be a text document. On a fresh Windows install the extensions of known file types are hidden by default. Go to Organize -> Folder and search options -> View -> Uncheck Hide extensions for known file types. Then rename bitcoin.conf.txt to bitcoin.conf. Now you have a CONF file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.