1

I am using Ubuntu. I cannot compile the Virtual Machine. If i direct to gitian-builder and type into the Terminal: sudo bin/make-base-vm -a i386. It compiles for approximately 3 minutes and than it crashes with this Error:

W: --force-yes is deprecated, use one of the options starting with --allow instead.
E: Sub-process /usr/bin/dpkg returned an error code (1)

Terminal:

root@user-MS-7366:/home/user# cd git*
root@user-MS-7366:/home/user/gitian-builder# sudo bin/make-base-vm --arch amd64
2017-01-09 15:53:37,004 INFO    : logging to file: /tmp/tmpXaV7Vf
2017-01-09 15:53:37,173 INFO    : Calling hook: preflight_check
2017-01-09 15:53:37,200 INFO    : Calling hook: set_defaults
2017-01-09 15:53:37,200 INFO    : Calling hook: bootstrap
2017-01-09 15:58:05,544 INFO    : Calling hook: configure_os
Extracting templates from packages: 100%
2017-01-09 16:04:46,669 INFO    : W: --force-yes is deprecated, use one of the options starting with --allow instead.
2017-01-09 16:04:50,371 INFO    :
2017-01-09 16:04:50,371 INFO    : Current default time zone: 'Etc/UTC'
2017-01-09 16:04:50,374 INFO    : Local time is now:      Mon Jan  9 15:04:50 UTC 2017.
2017-01-09 16:04:50,374 INFO    : Universal Time is now:  Mon Jan  9 15:04:50 UTC 2017.
2017-01-09 16:04:50,374 INFO    :
2017-01-09 16:04:52,946 INFO    : Generating locales (this might take a while)...
2017-01-09 16:04:54,025 INFO    :   en_AG.UTF-8... done
2017-01-09 16:04:55,088 INFO    :   en_AU.UTF-8... done
2017-01-09 16:04:56,159 INFO    :   en_BW.UTF-8... done
2017-01-09 16:04:57,231 INFO    :   en_CA.UTF-8... done
2017-01-09 16:04:58,297 INFO    :   en_DK.UTF-8... done
2017-01-09 16:04:59,359 INFO    :   en_GB.UTF-8... done
2017-01-09 16:05:00,424 INFO    :   en_HK.UTF-8... done
2017-01-09 16:05:01,485 INFO    :   en_IE.UTF-8... done
2017-01-09 16:05:02,547 INFO    :   en_IN.UTF-8... done
2017-01-09 16:05:03,677 INFO    :   en_NG.UTF-8... done
2017-01-09 16:05:04,740 INFO    :   en_NZ.UTF-8... done
2017-01-09 16:05:05,812 INFO    :   en_PH.UTF-8... done
2017-01-09 16:05:06,881 INFO    :   en_SG.UTF-8... done
2017-01-09 16:05:07,954 INFO    :   en_US.UTF-8... done
2017-01-09 16:05:09,021 INFO    :   en_ZA.UTF-8... done
2017-01-09 16:05:10,086 INFO    :   en_ZM.UTF-8... done
2017-01-09 16:05:11,145 INFO    :   en_ZW.UTF-8... done
2017-01-09 16:05:11,146 INFO    : Generation complete.
Extracting templates from packages: 100%
2017-01-09 16:07:45,694 INFO    : W: --force-yes is deprecated, use one of the options starting with --allow instead.
2017-01-09 16:07:45,695 INFO    : E: Sub-process /usr/bin/dpkg returned an error code (1)
2017-01-09 16:07:45,696 INFO    : Cleaning up
2017-01-09 16:07:46,846 ERROR   : Process (['chroot', '/tmp/tmpbRsGQM', 'apt-get', '-y', '--force-yes', 'dist-upgrade']) returned 100. stdout: Reading package lists...
Building dependency tree...
Reading state information...
Calculating upgrade...
The following packages will be upgraded:
  apt apt-utils base-files bash bsdutils console-setup console-setup-linux
  dh-python distro-info-data dpkg gnupg gpgv grep ifupdown init
  init-system-helpers initramfs-tools initramfs-tools-bin initramfs-tools-core
  isc-dhcp-client isc-dhcp-common kbd keyboard-configuration klibc-utils less
  libapparmor1 libapt-inst2.0 libapt-pkg5.0 libblkid1 libc-bin
  libdns-export162 libexpat1 libfdisk1 libgcrypt20 libgnutls-openssl27
  libgnutls30 libidn11 libisc-export160 libklibc libmount1 libp11-kit0
  libprocps4 libpython3.5-minimal libpython3.5-stdlib libsmartcols1
  libssl1.0.0 libsystemd0 libtasn1-6 libudev1 libuuid1 locales lsb-base mount
  multiarch-support procps python3.5 python3.5-minimal sudo systemd
  systemd-sysv tar tzdata udev util-linux vim-common vim-tiny
66 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 27.7 MB of archives.
After this operation, 233 kB of additional disk space will be used.
[installing packages]

Configuration file '/etc/sudoers'
 ==> Modified (by you or by a script) since installation.
 ==> Package distributor has shipped an updated version.
   What would you like to do about it ?  Your options are:
    Y or I  : install the package maintainer's version
    N or O  : keep your currently-installed version
      D     : show the differences between the versions
      Z     : start a shell to examine the situation
 The default action is to keep your current version.
*** sudoers (Y/I/N/O/D/Z) [default=N] ? dpkg: error processing package sudo (--configure):
 end of file on stdin at conffile prompt
[... // installing]
update-initramfs: Generating /boot/initrd.img-4.4.0-57-generic
Errors were encountered while processing:
 sudo
Extracting templates from packages: 100%
W: --force-yes is deprecated, use one of the options starting with --allow instead.
E: Sub-process /usr/bin/dpkg returned an error code (1)

root@user-MS-7366:/home/user/gitian-builder# 

What am I'm missing?

I need to use the Gitian Builder: https://github.com/devrandom/gitian-builder I followed these steps: https://coinaxis.com/index.php/tutorials/entry/how-to-do-a-gitian-build-for-litecoin-tutorial-coinaxis

Thanks.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.