3

I have bitcoind 0.13.1 running on a Raspberry Pi. I can see it on the bitcoin network using bitnodes.21.co but I can't connect to it locally with bitcoin-cli.

My bitcoin.conf is:

rpcuser=xxx
rpcpassword=xxx
listen=1
server=1
dbcache=50
daemon=1
testnet=0
maxuploadtarget=200

I tried:

curl --user xxx --data-binary '{"jsonrpc": "1.0", "id":"curltest", "method": "getinfo", "params": [] }' 127.0.0.1:8332

and I got:

curl: (7) Failed to connect to 127.0.0.1 port 8332: Connection refused

Netstat:

sudo netstat -tulpn | grep bitcoin

gives:

tcp        0      0 0.0.0.0:8333            0.0.0.0:*               LISTEN      620/bitcoind    
tcp6       0      0 ::1:8332                :::*                    LISTEN      620/bitcoind    
tcp6       0      0 :::8333                 :::*                    LISTEN      620/bitcoind'

I had a crash a couple of days ago and had to recover wallet.dat from a backup. After the crash the time on the pi was an hour slow. I had to stop and start ntp to get it correct. I also did an apt-get update and upgrade after the crash. Until the crash this worked fine.

Finally I see that all the files in the dataDir are executable by everyone. The dataDir is on a USB stick that is mounted with:

/dev/sda1 /home/pi/bitcoinData vfat uid=pi,gid=pi,umask=0022,sync,auto,nosuid,rw,nouser 0 0

I am tempted to start over but would really like to understand why this has stopped working.

  • Have you tried 'curl' with password? curl -u xxx:xxx <...>? – Jonas Schnelli Mar 15 '17 at 7:43
  • I just tried, same error :-( – erols Mar 15 '17 at 8:00
  • Your rpc request works fine for me. So I changed bitcoin.conf and pasted exactly your file. Then I had the same error. But in fact, the only reason I had the error was because bitcoind was shutting down immediately (can see this from debug.log) due to change in txindex. So I added back txindex=1 in config file and now your request works fine (with -u xxx:xxx). My point is: are you sure bitcoindis actually still running when you launch request? (maybe it shuts itself down like it did for me). (I know your netstat output seems to indicate bitcoind is running though ...) – Sven Williamson Mar 15 '17 at 12:15
  • Thanks for trying Sven. bitcoind is definitely running. I can see it in top and ps. I will try txindex=1 – erols Mar 15 '17 at 12:18
  • Ok if you didn't have txindex=1 before then this will probably mess you up (some time consuming blockchain data processing). Anyway, for what it is worth I am on v0.14.0 and x86-64 debian (not Raspberry). Your config file works as is for me, but maybe the settings rpcport=8332 and rpcallowip=0.0.0.0/0 (or something in 127.) will help. – Sven Williamson Mar 15 '17 at 12:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.