0

I am using code from GitHub.

Once I run composer its gives error as:

C:\wamp64\www\bitcoin-php-master>composer require bitwasp/bitcoin Using version v0.0.33.1 for bitwasp/bitcoin ./composer.json has been updated Loading composer repositories with package information Updating dependencies (including require-dev) Your requirements could not be resolved to an installable set of packages.

Problem 1 - The requested package bitwasp/bitcoin No version set (parsed as 1.0.0) is satisfiable by bitwasp/bitcoin[No version set (parsed as 1.0.0)] but these confl ict with your requirements or minimum-stability.

Installation failed, reverting ./composer.json to its original content.

enter image description here

1

Since Bit-Wasp/bitcoin-php has its own composer.json file, after cloning you should just run:

composer install

If there is still some issue, run the following command to diagnose the problem:

composer self-update
composer diagnose

Otherwise report it at the project page.

| improve this answer | |
0

You have to clear composer.json and try again.

| improve this answer | |
  • Hi Thank you for reply. Not able to understand correctly about clear composer.json. What exacts i have to do. – Mayur Dhudasia Apr 9 '17 at 14:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.