2

I've created a docker container of an ubuntu machine, loaded it up with all the dependencies specified in the unix build doc and then built bitcoin and run it with the following command:

./src/bitcoind

after that there's no output or evidence that anything is happening, the terminal is just hanging there, clearly something is going on- but I don't know/can't see what it is.

how can I examine the activity? For instance, see the coins that are being generated in my wallet, etc.

I've tried this proposed solution, i.e. to write

bitcoind getinfo

but I got the error

Error: There is no RPC client functionality in bitcoind anymore. Use the bitcoin-cli utility instead.

Regarding -regtest

I tried with:

./src/bitcoin-cli -regtest &

and I got the error:

too few parameters (need at least command)
5

the terminal is just hanging there

Yes, if you want it to run in the background, you need to run with the -daemon flag.

how can I examine the activity?

You can look at the debug.log file (in the datadir), or you can run with the -printtoconsole flag. You can increase the verbosity using the -debug flag (or specify a specific category, for example -debug=mempool; to see the various debug categories and more, use -help).

For instance, see the coins that are being generated in my wallet, etc.

The built-in miner was removed in Bitcoin Core v0.13.0, as it was not even useful for testing purposes anymore. If you want coins, you'll need to either buy them, get someone to send you some, or run a mining setup (which at the time of writing almost certainly requires custom ASIC hardware).

I've tried this proposed solution, i.e. to write

bitcoind getinfo

You need to use bitcoin-cli now to communicate with bitcoind (since a few years ago...). The getinfo command still works but is deprecated. More specific information can be obtained using the RPC calls:

  • getblockchaininfo
  • getpeerinfo
  • getnetworkinfo
  • getwalletinfo
  • gettxoutsetinfo
  • getaddednodeinfo
  • getmempoolinfo
  • I think I sort of got what I was looking for with this one ./src/bitcoin-cli getinfo, but actually I don't want to connect to the real bitcoin network, I want to start over from scratch, create my own personal testnet, do you know how to do this? – smatthewenglish Apr 18 '17 at 13:40
  • so then does that mean that I can't use bitcoin core for creating a testnet, since it can't mine? – smatthewenglish Apr 18 '17 at 13:44
  • how to get around this error error: Could not locate RPC credentials. No authentication cookie could be found, and no rpcpassword is set in the configuration file (/root/.bitcoin/bitcoin.conf) – smatthewenglish Apr 18 '17 at 13:47
  • That means bitcoind is not running (or perhaps you're running it with -testnet or -regtest but not passing that same argument to bitcoin-cli?). – Pieter Wuille Apr 18 '17 at 13:48
  • 2
    I would suggest to start in -regtest mode. You'll get an empty chain with only a genesis block, and no default connections anywhere. You can then use -connect to add nodes to your network and experiment. If you're further ahead, modify chainparams.cpp to add a definition for your own network and logic to select it. – Pieter Wuille Apr 18 '17 at 14:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.