I'm new to bitcoin and my situation is this: I installed Bitcoin Classic wallet, then sent bitcoins to it from Coinbase before the entire blockchain was finished syncing. The transaction timed out and the bitcoins never appeared in my wallet. A week later I tried reloading the entire blockchain, and the transaction came through to my wallet at that time. However, the bitcoins are listed as watch-only. I have tried dumping the private key for that address on console for my wallet, but the results continue to say that the private key for that address is unknown. What do I do about this? How can I make my bitcoins spendable? Any help would be appreciated.

  • See if your priv key really matches the address. You extract the priv key from the wallet with the dumpprivkey command. This should return the private key which will start with the number 5. This is the private key, that you can use to spend bitcoins. Attention: you will never (!) enter your priv key on a website to see if it is correct... You may also want to check the value of bitcoins on your address on blockchain.info. See if values are displayed. If yes, the privkey could be used to be imported in a new wallet, and then you'd be able to spend from there... Commented Apr 29, 2017 at 7:07
  • Thanks so much for the info. So when I use the dumpprivkey command, the results always say "Private key for address ___ is not known." So it seems I'm not able to extract the private key at all??
    – lobake
    Commented Apr 30, 2017 at 15:13
  • yup :-( Somehow the connection between your privkey and pubkey is broken, and the root cause can be many... I guess somewhere in the installation. Do you have a backup, that you could use, to bring back the first installation of your bitcoin wallet? This would be the only tip I have. Otherwise you'd run into data recovery issues, that certainly go beyon the communities goal here. Commented Apr 30, 2017 at 17:44
  • Thanks again. I guess I'll have to see if I can find a backup. If that doesn't work, or if I don't have one, do you have any recommendations of someone I can contact for help with data recovery?
    – lobake
    Commented May 1, 2017 at 4:34
  • @pebwindkraft No connection is broken. By definition a watch-only address is one you don't have (and never had) the private key for. Commented Jan 5, 2018 at 8:28