2

I can't open either of my 2 Multibit HD wallets. It says "Password did not unlock the wallet" on both. I have tried restoring from all the possible backups, my passwords are correct and my secret words successfully verify each time. On clicking "next" I get:-

1) TICK. Backup location created 2) CROSS. Wallet created. 3) TICK. Security certificates 4) CROSS. Wallet is synchronising. Please wait until complete.

The finish button is grey, the wallet seems to do nothing else - it never synchs. I am 3 coin worth $6k down at the moment. I am also trying to restore my wallet in electrum, but because I don't know how to select the wallet location from Multibit HD I am struggling. Repeat, I have all correct info required for backup. Also, I have my .zip.aes files - I stored them on the root of C: I can't seem to open them with AES Decrypt, tried using my 12 word seed chain and the password on the wallets. Plz help, its all our company bitcoin sales for the past 6 months...

Yes, I have gone through other forum posts, but am a little out of my depth and can't understand why with all the right backup info, I get no restoration. I will stick to Electrum in future, but had no problems previously with Multibit standard , the upgrade has screwed me good and proper!

MJT

2

MultiBit HD bugs

There are several issues:

  1. A correct password doesn't unlock the wallet (#753 on github).
  2. The restore process doesn't work if there's already a wallet in the directory that MHD uses for the restore (the "CROSS. Wallet created.").

In my experience even a successful restore into a fresh new location won't help with the password problem, on any MHD version.

Coin recovery

It is only sensible to move the coins into a different wallet. This can be done by importing the private keys for the addresses that hold your coins.

You'll need the wallet recovery seed, i.e. the set of words the wallet gave you when you created it.

Getting the private keys

  1. Go to https://iancoleman.github.io/bip39/, scroll down to 'Offline usage', create an offline copy and open it in browser.
  2. Input your seed in 'BIP39 Mnemonic'.
  3. Under 'Derivation Path', select 'BIP32'.
  4. For 'Client' select 'Multibit HD'.
  5. The 'Derived Addresses' list now has your wallet's usable addresses and their private keys. Figure out which addresses hold the coins (e.g. look up on blockchain.info). Copy those private keys.
  6. Some coins may be on "change addresses", which have different derivation path:
    • For 'Client' select 'Custom derivation path'
    • For 'BIP32 Derivation Path' input "m/0'/1"
    • Repeat step 5. with the updated list of derived addresses.

Importing private keys

Pick another wallet software and consult its documentation about private keys import.

For instance, Electrum allows to create a seedless wallet that can do this. That should allow to control the coins again and send them into another wallet (use the seedless wallet only temporarily).

1

Install Multibit HD on another computer. Do a "restore wallet". Type in your 12 word seed. The new installation should show all your past transactions and restore your coins.

The new installation will ask you for a password. You can use the same one or select something new.

Lots of people are complaining about the password bug. I would suggest you move the coins to another wallet at some point.

0

I had the password but not the seed. Absolutely sure of the password. Same error message "The password did not unlock the wallet". Another way of recovering the seed from the password is this. It may be from the Multibit developers(?):

https://github.com/Multibit-Legacy/read-multibit-wallet-file

You may have to sudo some of the commands, find the correct paths, etc. Don't give up until it installs and finds the right file!

Then, you use the command line tool to input your password and it returns your seed (the 12 words in plain text, be careful!). Create a wallet with that seed in another wallet of your choice, wait until it is completely restored, then transfer the bitcoins to a third wallet that you'll use henceforth.

Worked for me even though the wallet when opened in multibit was broken. Hope it helps someone else!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.