1

As the title says, I have an interesting difficulty and have no idea how to resolve it. I installed bitcoin core on the linux partition of my macbook, but was not aware that it needed as much disk space as it did to update the blocks. It says it is "4 years and 40 weeks behind", and will only run for a short time before giving me the error that there is insufficient space on the disk.

This is a problem as I have already initiated a transfer of bitcoin from coinbase to the address provided to me by bitcoin core.

It says that recent transactions may not be visible until my wallet has finished synchronizing with the network, but I don't have sufficient space to do so.

I tried to use GParted to resize the partition, but it would not allow me to.

Any ideas??? It was quite a bit of money I have lost.

1

I think you can copy the wallet.dat file if you want to run the bitcoin software on another drive/computer and import it there.

Import wallet.dat into a new Bitcoin-Qt client

1

You can set Bitcoin Core to run in "pruning mode" which will then keep only the last few blocks instead of the whole blockchain.

To enable pruning, you add the line

prune=<n>

to your configuration file whereby you replace <n> with the number of megabytes of blockchain data you want to keep. The minimum is 550.

The configuration file can be found in the Bitcoin data directory by default it's found at ~/.bitcoin on Linux. The configuration file is called bitcoin.conf. If the file doesn't exist yet, you can just create a text file by that name.

Also see:

  • Where exactly do I need to put the "prune=<N>" command? It mentions the command line but I'm afraid to say I'm not sure which one it's referring to. It also says I can add it into the bitcoin.conf file but when I do it and try to save it, it said that an error occurred while updating the file. – Jovan Poursamadi May 24 '17 at 0:58
  • I found the console in the debug window. There is no command "prune" but there is "pruneblockchain" followed by a value. I set value "1000" and it told me "cannot prune blocks because node is not in prune mode". – Jovan Poursamadi May 24 '17 at 1:10
  • It's a start-up parameter. Alternatively, you can put it in the bitcoin.conf. It doesn't work in the console. – Murch May 24 '17 at 1:57
  • 1
    Adding that setting in bitcoin.conf is what I'd recommend - that makes it harder to forget to add it, which can result in start-up failures. – wumpus May 24 '17 at 6:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.