3

i am running Bitcoin Core 0.14.1 on a Centos6 Server. I had several transactions (receive, send) in the last days, and everything was fine.

I always did my transaction with the bitcoin-cli sendtoaddress ADDRESS AMOUNT ... and that worked fine. Always after some minutes i could see my unconfirmed transactions at Blockchain.info

But yesterday i made a new transaction same as always and i get an transactions id successfully, but i cant find my transaction in the Blockchain. And the receiver does not the transaction also.

What i have tried:

  • I wait more than 24 hours ( but my transaction is not showing up in blockchain, and wasnt include in any block)
  • I turned off the IP Tables and make sure that the Wallet is connected to the network.

  • I stooped Bitcoin with bitcoin-cli stop and made an recan with bitcoind -rescan

  • I stooped Bitcoin with bitcoin-cli stop and made an recan with bitcoind -zapwallettxes
  • I deleted the memorypool.dat in .bitcoin directory
  • I reload the complete Blockchain

Who has the solution?

  • What are you trying to achieve: Resending or recovering? Is the transaction still showing as unconfirmed on your server? Did the transaction get malleated and confirmed? Have you checked whether the transaction's inputs are still in your wallet? Did you delete the mempool file and do -zapwallettxes in the same go? – Murch May 27 '17 at 20:32
  • I've guessed at your goal to give the question a more speaking title. If I guessed wrong, please edit to improve. :) – Murch May 27 '17 at 20:35
  • The amount is subtracted from my balance and its shown in my wallet as unconfirmed transaction. I want to resend it. – John Doe May 27 '17 at 21:15
3

If you have the transaction ID you can get the raw hex transaction via:

bitcoin-cli getrawtransaction <txid>

That will produce a rather long string <rawtx> which is the serialized transaction. You can then use

bitcoin-cli sendrawtransaction <rawtx>

or any of the web interfaces that allow pushing a transaction (just search for pushtx and I'm sure you'll find a few providers). The raw transaction does not contain any private information. It is safe to publish, however services may attribute the transaction with your IP if you use them, so try sendrawtransaction first, which is the exact same behavior your client would use anyway.

Notice that your client will also automatically retry your wallet transactions every once in a while, so manual intervention may not be needed. It could be you haven't attached a large enough fee for the TX to be propagated in the network.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.