3

Multibit HD 0.5.1

This is my wallet's transaction list and amount:

image

I am having the following issues:

  1. I don't understand why do I have 0.07btc ~ 224.59$ unconfirmed for a month by now.
  2. I have three transactions there that are still sending/receiving... What the hell?

These are the transactions in the blockchain:

I have tried the following solutions that failed:

  1. Wallet repair multiple times
  2. Wallet removal and reinstallation, from the seed words
  3. Wallet recovery on another computer

What I didn't try:

  1. Double spend (how do I do it in Multibit HD?)
  2. Remove transaction from mempool or wtvr (how do I do it in Multibit HD?)
2

I got help from BTC Portugal (Portuguese slack channel, thank you @riclas, @shutaru and @malmen) and was able to solve this issue.

This is what I did (ETA: 10 minutes):

  1. Close all running Multibit HD wallets you have. I really mean all, no computer in this planet should be running your wallet at this moment.
  2. On a "new", clean computer, or in a Virtual Machine, install Multibit HD, a fresh installation.
  3. When the new Multibit HD installation asks you, instead of creating a new wallet, chose the restore wallet option.
  4. Insert your seed words and date.
  5. Voila! It will now take some minutes to synchronize your wallet with the chain, but it should load only the confirmed transactions.
  6. Go to the other computers, uninstall Multibit HD completely.
  7. Make sure you delete everything in folders such as C:\Users\<user name here>\AppData\Roaming\MultiBitHD (or /Users/<user name here>/Library/Application Support/MultiBitHD/ for OSX) or simply search for MultiBitHD files on your disk and delete them all.
  8. Install the wallet once again in those computers and recover just like you did in steps 3 and 4.
  9. Profit!

If you are really in a rush, just perform steps 6, 7 and 8.

Don't do any of this if you don't know your words and date for recovery!

UPDATE: This doesn't actually solve the issue. In fact the wallet thinks that all your transactions are confirmed, until you try to spend the money. Then you'll get a Low spendable balance detected. some of your bitcoins are tied up with ongoing transactions. error.

The thing is that the wallet refuses (or the network refuses) to double spend that money, because they see the unconfirmed requests already broadcasted.

For what I've read these requests will never timeout from the mempool. This is a known issue of BTC, and is making this coin hard to scale to the rising numbers of transactions (as of now only 3 transactions are processed per minute, which is ridiculous).

The only way I can perceive now to "solve" these unconfirmed transactions, is to use accelerators.

These accelerators are basically mining pools (a huge team of miners), where you ask them "pretty please" to consider adding your transaction to their next created block. This will confirm your transactions. However, this solution is at very least, not accessible.

You can try asking it for free here: https://www.viabtc.com/tools/txaccelerator/

After I get my money back, I'll consider not using Multibit HD anymore, since issues like these made me lose some money so far...

  • I have a same problem (a pending send request that I want to remove it), and I follow your instruction, first it works and the second computer shows only my confirmed transactions, but when I try to spend coins (to another address), it fails with a double spending error and I cant broadcast new transaction. after that the pending transaction appears! – Reza Afzalan Jun 6 '17 at 20:18
  • Yes you're right... Actually I just tried that and got the same issue. The problem is that the wallet already broadcasted the transactions and is unable to double spend at will (I don't know why multibit creators decided things this way). The only way I find as an alternative to solve this is asking a mining pool to put our transactions in their next blocks. ViaBTC has an option for that (which is not working at the moment, but I will keep trying this week). link: viabtc.com/tools/txaccelerator – PedroD Jun 6 '17 at 20:42
  • there are some posts that say double spending is possible e.g. bitcoin.stackexchange.com/questions/41399/… , but they said inputs must be the same. I don't know that means same amount or address or both, in my case I tried to send different amount to another address. – Reza Afzalan Jun 6 '17 at 20:51
  • what did you do? did you send the same amount? – Reza Afzalan Jun 6 '17 at 20:55
  • That might work, but it seems risky to upload your private keys online. I am going to read this book (github.com/bitcoinbook/bitcoinbook) and the bitcoin dev wiki to make sure that I don't mess things up. – PedroD Jun 6 '17 at 20:55
0

I had the same problem for weeks. Last night (6 June 2017) I checked and noticed that the unconfirmed bits of my funds were finally confirmed. Perhaps Multibit are at long last and sorting out their software problems

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.