1

My Electrum 2.8.2 shows "No FX rate available" at the bottom and shows "No Data" for the balances. Also, I'm missing a transaction that someone said they sent to me. How do I fix this to see my latest transactions and USD balances?

enter image description here

4
  • Is it possible that your Electrum client isn't connected to an Electrum server?
    – Murch
    Jun 7 '17 at 18:04
  • It says it is. There is text in the 'Console' tab and the green light is on in the corner.
    – Chloe
    Jun 7 '17 at 18:07
  • Perhaps you could add a bit more information what you've tried.— I assume that you've tried to "turn it off and on" again? ;)
    – Murch
    Jun 7 '17 at 18:11
  • 1
    Try connecting to a different Electrum server.
    – Andrew Chow
    Jun 17 '17 at 17:58
3

I've just had this problem as well. It looks like Electrum gets its currency information by default from the BitcoinAverage website. You could try to select a different source of information. Try and see if this helps:

Go to Tools > Preferences > Fiat > Source > Select something like BlockchainInfo

2
  • This is a partial answer and could be improved by addressing the missing transaction reported by the asker.
    – Murch
    Jun 18 '17 at 18:05
  • Turns out the sender sent to the wrong address, an old address from an old wallet, but luckily I still had the key. Cost me a few bucks to sweep it though.
    – Chloe
    Jun 18 '17 at 20:11

Not the answer you're looking for? Browse other questions tagged or ask your own question.