1

I apologise if I put this question in wrong place.

I created new altcoin based on litecoin source code. All looks ok, wallet and wallet-qt are compiled and running. However when I trying to mine using cpuminer (minerd) I getting 500 error.

I put this settings to *coin.conf file:

rpcuser=miner1
rpcpassword=some_password_here
rpcallowip=127.0.0.1
rcpport=9332
server=1
gen=0

Command for minerd:

minerd -a scrypt -o http://127.0.0.1:9332 -O miner1:some_password_here

Minerd output:

[2017-06-29 10:38:02] 1 miner threads started, using 'scrypt' algorithm.
[2017-06-29 10:38:02] HTTP request failed: The requested URL returned error: 500 Internal Server Error
[2017-06-29 10:38:02] json_rpc_call failed, retry after 30 seconds

What I'm doing wrong? Is there something else I have to do to "launch" my new crypto currency?

Thank you for your help.

2
  • 1
    are you running your coin wallet? try removing the http:// part of the url
    – Albert S
    Commented Jun 29, 2017 at 22:53
  • Yes, I run 3 wallets, each on separate VM, they can connect to each other.
    – Wojtek B
    Commented Jun 30, 2017 at 9:26

3 Answers 3

1

The problem is that the Litecoin I used 0.8.4.7, does not have embedded mining software.

I ended up with two solutions:

  1. Create mining pool and then:
    • connect nodes to each other
    • run the miner on my mining pool
  2. Compile and run (-gen=1 option) old Litecoin node then connect to th e other nodes one.
1
  • Welcome to Bitcoin.SE! You can help the site by marking answers as accepted if they are correct and address the question so that the question does not remain as "unanswered".
    – Willtech
    Commented Mar 19, 2018 at 11:28
0

remove gen=0 whit configuracion --> yourcoin.conf

and execute

./minerd -a scrypt --url=http://"YOUR IP":"YOUR PORT"/

1
  • gen=0 has nothing to do with it by default gen means generate coins using core and it already disabled.
    – zhiyan114
    Commented Apr 20, 2018 at 13:13
0

I got this working by running two instances of wallet-qt on different ports (port= and rpcport= in the .conf file) and having one connect to the other. It seems the wallet needs at least one peer before it will talk to cpuminer.

2
  • This will work for old Litecoin. I was working on 0.8.7.4, you can't mine on it because the mining part is removed from the source code. I ended up creating own mining pool and it's work as expected. Second option is to compile the old software with mining code and connect it to the new nodes... But now I building mining pools, much easier to me.
    – Wojtek B
    Commented Oct 19, 2018 at 7:41
  • It doesn't need the "mining part". I didn't have to use the "gen=1" setting; I used cpuminer to do the mining. Commented Oct 20, 2018 at 8:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.