0

I had this running perfectly and the blockchain was synching and at about 80% completion. I came home from work to a power outage.

I keep seeing to run bitcoin-qt, it doesn't appear that I have that. In /src/ I have bitcoin-cli, bitcoind, and bitcoin-tx. Obviously d is daemon, and -tx isn't what I want either. So I try

bitcoin-cli -datadir=/pi/home/bitcoin/ error: too few parameters (need at least command)

0

It seems like you simply haven't installed bitcoin-qt, if you install that then you can run it :)

I'm unsure exactly how the power outage and the datadir command at the end relate to the question though

  • Because I had this running smoothly before, the GUI was operable, the blockchain was ~80% completion. – HOOPYDOOP Jul 28 '17 at 14:13
0

Yes, the gui is bitcoin-qt - just copy it back in from the download if it is missing. Also, if you used the install command, have a look if it is in /usr/local/bin or similar, it should just run from the command line.

0

Have you followed the build instructions?

They are found here: https://github.com/bitcoin/bitcoin/blob/master/doc/build-unix.md

Make sure that you have installed all the related GUI dependences or else you will not have bitcoin-qt on your machine.

Also, bitcoin-cli is a command line tool to speak with your bitcoin node (bitcoind). You need to pass a command. The data-dir flag is just specifies a data directory. Try passing a command like getblockchaininfo

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.