4

I have a bitcoin-core node running on a Raspberry Pi on my local network. The node is publically visible and running fine (I can see it on bitnodes.21.co - it has connections and is synced to the latest block).

I have a Windows PC with a Bitcoin-Qt installation that I would like to connect only to the local node, only when I start it up it doesn't seem to connect. I'm starting it from a command line with

bitcoin-qt.exe -connect 192.168.0.6

The GUI just says "Connecting to peers" and Help > Debug shows 0 connections.

I can ping the Pi from the Windows machine and I can telnet to port 8333 on the Pi from the Windows machine, so I believe the network connectivity isn't the issue.

Any advice on how to diagnose what's going on? (RPC commands? Logs?)

Am I using the right command to connect?

1

It might be you need to add some lines in the bitcoin.conf file on the Raspberry Pi. This was taken from the github repo example of the bitcoin.conf file

##############################################################
##            Quick Primer on addnode vs connect            ##
##  Let's say for instance you use addnode=4.2.2.4          ##
##  addnode will connect you to and tell you about the      ##
##    nodes connected to 4.2.2.4.  In addition it will tell ##
##    the other nodes connected to it that you exist so     ##
##    they can connect to you.                              ##
##  connect will not do the above when you 'connect' to it. ##
##    It will *only* connect you to 4.2.2.4 and no one else.##
##                                                          ##
##  So if you're behind a firewall, or have other problems  ##
##  finding nodes, add some using 'addnode'.                ##
##                                                          ##
##  If you want to stay private, use 'connect' to only      ##
##  connect to "trusted" nodes.                             ##
##                                                          ##
##  If you run multiple nodes on a LAN, there's no need for ##
##  all of them to open lots of connections.  Instead       ##
##  'connect' them all to one node that is port forwarded   ##
##  and has lots of connections.                            ##
##       Thanks goes to [Noodle] on Freenode.               ##
##############################################################

# Use as many addnode= settings as you like to connect to specific peers
#addnode=69.164.218.197
#addnode=10.0.0.2:8333

# Alternatively use as many connect= settings as you like to connect ONLY to specific peers
#connect=69.164.218.197
#connect=10.0.0.1:8333

# Listening mode, enabled by default except when 'connect' is being used
#listen=1

# Maximum number of inbound+outbound connections.
#maxconnections=

#
# JSON-RPC options (for controlling a running Bitcoin/bitcoind process)
#

# server=1 tells Bitcoin-Qt and bitcoind to accept JSON-RPC commands
#server=0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.