0

I've followed the advice found here and also on the Github article linked from that post, but I'm still having issues decrypted a wallet backup using the latest version of Bitcoin Wallet on Android (v5.26 released 7/28/17)

I was able to take the BIN file in question and import that between Bitcoin Android wallets, so I know the backup is not corrupted and the password works.

When I run the openssl enc -d -aes-256-cbc -a -in <filename> command, targeting the BIN backup file, it prompts for the password, which is inputted. The resulting decryption fails.

Is there a change made to the encryption algorithm that I'm not taking into account? Any/all help is appreciated.

Thank you

EDIT: To be clear, I also attempted the openssl command string found on the Github article, but that also fails (it includes the -md md5 parameter)

1

i managed to decrypt a backup by doing this :

openssl enc -d -aes-256-cbc -md md5 -a -in ./walletbackupfile > decrypted_wallet

however, i have not managed to getting at the private keys from the output.

i have tried wallet-tool dump --dump-privkeys --password=..pin

but it seems like no private keys are dumped in the output

i have also tried wallet-tool raw-dump --dump-privkeys --password=..pin

that seems to dump some encrypted private keys of some kind, but i am not sure how to proceed from there.

  • Brilliant, thank you.. I was naive and didn't follow each step from that Github link, but after loading the bitcoinj wallet-tool I was able to successfully dump the private keys. – maff1989 Aug 3 '17 at 14:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.