1

I have two local bitcoin nodes, node1(192.168.105) and node2(192.168.1.101). Firstly, I start node1 to connect the bitcoin network to download some blocks. Then I delete the static dns seeds in file chainparam.cpp for both two nodes. So they both cannot connect to the bitcoin network.

I started node1 with “./src/bitcoind -datadir=/bitcoin_block -listen=1" and node2 with "./src/qt/bitcoin-qt -datadir=/bitcoin_block". And in order to connecting node1, using command "addnode 192.168.1.105:8333" on node2 through the debug window/console.

The status in node2 shows, enter image description here We can see that node2 has connected to node1, but cannot sync blocks from node1.

I checked the node2's debug.log and found "Ignoring getheaders from peer=0 because node is in initial block download". Then I changed the nMinimumChainWork value to a more smaller one and provide -maxtipage when starting node2 to make the following check failed(suggestions from Altcoin connecting nodes). But it still won't sych.

"chainActive.Tip()->GetBlockTime() < (GetTime() - nMaxTipAge)".

Is there anyone can give some advices here? It really stuck me here. Appreciate your help.

0

Then I delete the static dns seeds in file chainparam.cpp for both two nodes. So they both cannot connect to the bitcoin network.

They can still connect to the Bitcoin network without the DNS seeds. The DNS seeds are not the only way to connect to the network; there are numerous fallbacks, with DNS seeds themselves being a fallback too.

-datablock= is not a valid command line option. Did you mean to use -datadir?

Check in the debug window of both of your nodes; does node1 have a number of blocks that you expect it to have? Does node2 already have blocks that it downloaded very quickly and you didn't realize it?

Instead of using the addnode RPC, try using the -addnode or -connect startup options to connect your nodes.

  • 1. There's no connections after i deleted the DNS seeds and no data being downloaded. 2. Yes, I mean -datadir, sorry for the misunderstanding. 3. I checked there's no blocks in node1 except genesis block. And node2 did't get any blocks after I deleted its seeds in chainparam.cpp. – 李芳林 Aug 16 '17 at 1:16
-1

I was using bitcoin-0.14 and I forgot to change the chain limit parameter(nMinimumChainWork). It works fine after I lower down the limitation.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.