1

I have alredy looked at a lot of other similar questions here but they didn't involve my case or the solutions provided did not work for me. I'm trying to work in regtest mode and I'm using bitcoin core v0.15.0 on a Debian machine. My bitcoin.conf file looks like this:

$HOME/.bitcoin/bitcoin.conf ->
rpcuser=bitcoinrpc
rpcpassword=7bljxv........zabyi

I run the command

bitcoind -regtest -daemon

And then

bitcoin-cli -regtest getblockchaininfo

And it works fine, but if I try to run the following command:

bitcoin-cli -regtest generate 101

I get the following error:

error code: -32601
error message:
Method not found
1

Do you have wallet enabled? generate is a wallet RPC now since it needs to get an address from the wallet. If wallets are disabled, then generate will not work. If you want to mine without wallets being enabled, use generatetoaddress.

  • Thanks, I built bitcoin from source and I had misunderstood the consequences of --disable-wallet – Ivano Donadi Aug 16 '17 at 19:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.