0

I tried modifying the request so it would include a 3600 second expire time. (minutes - 1 hour) as shown in the example it returned an error the parameter was invalid. It shows - but as "null"

curl --data-binary '{"id":"curltext","method":"addrequest","params":{"amount":"3.14","exp":"3600","memo":"test"}}' http://127.0.0.1:7777

{"error": {"message": "Invalid parameters.", "code": -32602}, "jsonrpc": "2.0", "id": "curltext"}[

This is Electrum client daemon - not server - Linux (CentOS 7) - not Windows - it runs and returns a request fine without the "exp" parameter

0

Yes. Use "expiration": "3600" and it'll work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.