0

Saving the entire blockchain in my computer is taking mi a lot of space. I looked in this forum for a solution and I saw that there was an option to prune the node and save a lot of space. I followed the instructions, I went to the Bitcoin data directory, I created a file there and called it "bitcoin.conf" and I wrote "-prune=1100" in it. Nothing I expected happened, the space it took remained the same, it only started downloading a new blockchain called "testnet". Have I done something wrong? And how can I fix it in order to save space? My version of Bitcoin Core is v0.14..2

PS: Latter, I have discovered that, in fact, I have three Bitcoin data directories, and suddenly I have doubts about in which of them shall I place my "bitcoin.conf". Is having three directory data how it shall be? And in which of them shall I place my "bitcoin.conf".

enter image description here

enter image description here

  • Can you post exactly the contents of your bitcoin.conf file? Can you also post the command that you are using to start Bitcoin Core with (if you are on windows, right click the shortcut you are using and copy the contents of the Target box). – Andrew Chow Aug 27 '17 at 16:44
  • Can you post exactly the contents of your bitcoin.conf file? prune=1100 And I am using Windows 10. I am not a computer expert so I do not understand the rest of the question. – Ander Aristondo Aug 27 '17 at 16:54
  • In the config file you need to use "prune=1100", not "-prune=1100". Is that the problem? – Pieter Wuille Aug 27 '17 at 16:58
  • I have tried both ways and it hasn´t work in any of both. Just now I have "prune=1100" – Ander Aristondo Aug 27 '17 at 17:00
  • 1
    Possible duplicate of Can Bitcoin-Qt be configured to trim the blockchain? – MCCCS Aug 28 '17 at 8:11
4

From your description it sounds to me that you may have edited your configuration file while Bitcoin Core was already running.

prune=1100 is a startup parameter. It will take effect once you restart the program.

  1. If you add a parameter to the startup instructions, parameters start with a dash (-prune=1100), e.g.:

    "C:\Users\<username>\AppData\Roaming\Bitcoin\bitcoin-qt.exe" -prune=1100
    

    Please make sure you use the correct path for the actual directory you installed Bitcoin to.

  2. If you add it to the configuration, the parameter must be listed without a dash in the bitcoin.conf:

    prune=1100
    

    If you're unsure how to locate your Bitcoin data directory, please see: Where is the configuration file of Bitcoin-Qt kept?

There is no need to manually delete any files from your Bitcoin directory, or to start over the initial blockchain download to enable pruning. You merely need to restart Bitcoin Core after you've edited the bitcoin.conf. If you don't know how to restart a program, you may find it simpler to shut down and restart your computer.

  • How do I access to the startup instructions? And, is restarting the program, only, to close and open the program again (becouse I have already tried that)? Or, do I have to do something more? – Ander Aristondo Sep 5 '17 at 17:20
  • Yes, go to the menu, quit the program, start it again. At this point the bitcoin.conf gets used to initialize the program. Note that the standard "close window" operation is probably just hiding the program. You have to quit it, not hide it. – Murch Sep 5 '17 at 17:21
  • I have tried in different ways, I am sure I have restarted Bicoin Core, but it did not work. Now, I have discovered a new things that I will edit in the question. – Ander Aristondo Sep 7 '17 at 19:10
  • @AnderAristondo Use the folder from the first picture. Put the bitcoin.conf file there. – Nick ODell Sep 7 '17 at 19:12
-2

I have previously done this.

Go to your blockchain folder. Delete all blockchain files (blk***.dat and rev***.dat) except the two most recent ones for each file set (blk and rev). I've done that with no problems in the past.

****WARNING**** Your results may vary! ****WARNING****

The only risk is that you might have to re-download the whole blockchain again. Always have a backup of your wallet.dat file too!

The "most recent" files I'm referring to are the ones with the highest numbers. Mine currently go up to "rev00973.dat". If I were trying to manually prune my files, I'd delete "blk00000.dat" through "blk00971.dat" and "rev00000.dat" through "rev00971.dat".

NOTE: At least as of 8/27/2017 this method no longer works. I will update this if I am able to find a virtually similar method that does work.

  • That should have been enough. You could always undelete the files instead of re-downloading. I will try it on mine right now to see if it still works. Did you delete the "index" subfolder by accident? – Mine Aug 27 '17 at 17:17
  • Okay, disregard my answer, I just tried it myself and it wanted to re-download the blockchain too. If it wants to re-download the blockchain, then that means my method no longer functions as I have described it. And of course, I can't undelete all the files, lol, now I have to download the whole blockchain again. Well, hopefully someone else will have a better answer or I will figure out a better answer. one or the other... – Mine Aug 27 '17 at 17:23
  • Ok. Thank your for your efford Mine. – Ander Aristondo Aug 27 '17 at 17:41
  • I clearly left it as "no longer works" and I get a negative vote? really? God forbid I leave it as a reference. Not to mention I want to double check and see if I need to tweak my instructions slightly. After all, its taking me about 2 days to re-download the blockchain.... – Mine Aug 28 '17 at 16:57
  • 3
    What you're suggesting was never a supported configuration, and likely only worked as long as nobody tried to download any of those blocks from you. I'm not downvoting because it's outdated - I'm downvoting because suggesting to randomly delete files is terrible advice regardless. – Pieter Wuille Sep 9 '17 at 0:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.