5

I am using bitcoind json rpc api to send bitcoin to multiple bitcoin addresses. I am using sendrawtransaction. When i have 24 unconfirmed payments sent from my account, i can't send anymore because i get this error :

64: too-long-mempool-chain

I have increased the maxmempool to 1500 but it still doesn't fix it.

root@B2:~# bitcoin-cli getmempoolinfo

    {
      "size": 3946,
      "bytes": 1789073,
      "usage": 6043088,
      "maxmempool": 1500000000,
      "mempoolminfee": 0.00000000
    }

I use Ubuntu on a 32GB RAM , 4TB HDD server.

Any ideas on how to fix it ? I want to be able to create for example 300 unconfirmed transactions and not to receive that error.

  • 1
    Have you tried -limitancestorcount and/or -limitdescedantcount? – Nate Eldredge Sep 5 '17 at 16:53
  • No. Do i have to put that into the bitcoin.conf ? Thanks – Adrian Sep 5 '17 at 17:17
  • Either in bitcoin.conf or on the command line. These are debug/testing type options so if you want to know more you probably have to read the source code. – Nate Eldredge Sep 5 '17 at 18:02
3

You will not be able create unconfirmed chain for 300 transactions. Bitcoin core default limit is 25 transactions. In case you modify this parameter on your local node, network will not accept tx chain longer then 25 tx. You have to rebroadcast transactions again after your first batch (25) confirmed.

-1
-limitancestorcount

Do not accept transactions if number of in-mempool ancestors is n or more

and

-limitdescendantcount

Do not accept transactions if any ancestor would have n or more in-mempool descendants

This has fixed my problem. Thanks Nate Eldredge

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.