0

I'm having this bizarre problem. I've got this address A where I received two deposits, both are confirmed. I consolidated all my balance in a single address B (i.e. I sent my full balance to B). Since I moved my full balance I would expect all my addresses to be zero (except for B), but I noticed that address A has now non-zero balance: only one of the two deposits was used (let's call this output X). My guess is that the balance I'm getting with getinfo and getbalance is not actually my full balance and it's missing output X. Do you have any idea what may be happening? Things I've tried:

  1. X appears unspent in block explorer
  2. I ran gettxout with X and it correctly returns information (meaning X is actually not spent)
  3. I ran listunspent and I'm not getting X (meaning it's spent?)

Thanks in advice!

  • What does the transaction you moved it with look like? – weston Sep 6 '17 at 0:14
  • I'm not sure what you mean. It's a standard transaction. – Paul Sep 6 '17 at 4:19
  • The blockchain is transactions, that's it. If there is a problem it will be in the transaction. If you locate your transaction on the block chain you can see if X was involved at all. Also, did you try listunspent X include_unsafe, to see if locally you have X in an unconfirmed transaction maybe? – weston Sep 6 '17 at 10:51
  • X was not part of the consolidation. This led me to think that X was not being counted as part of my balance. I confirmed this by creating a raw transaction that transfers X to consolidation address B, and then my balance magically increased by the amount in X. – Paul Sep 6 '17 at 13:11
  • Your balance where? This is very confusing, it's not at all clear what you had before or what you have now or what you did or indeed what your problem is. – weston Sep 6 '17 at 13:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.