1

I have installed bitcoin core on mac and accessed the config file from the preferences tab on the bitcoin-qt.

Now, I have started testnet on it by the below settings.

testnet=1
server=1
rpcuser=xxxxx
rpcpassword=xxxxxx
rpctimeout=30000
rpcport=8332

I was able to run it properly. so I thought of accessing the RPC from other systems, so I have assigned a public IP to it and in the config file, I have mentioned

rpcallowip=0.0.0.0

Now, I tried starting qt on my mac but unable to start it as it throws Invalid -rpcallowip subnet specification and I could not open the preferences tab and then open the configuration file.

I have tried to access the folder directly by going to the location '~/Library/Application Support/Bitcoin/' but there was no folder named Bitcoin in my mac.

Is there any other location, where it would be?

I have searched the entire system using bitcoin.conf but found no results.

can anyone help me on this?

  • 1
    How did you put that config file (the top snippet) if there was non in that folder? The subnet specification might mean that you need to add a /n suffix to the IP, like 0.0.0.0/0. This is useful to allow all on local network, like this 192.168.0.0/24. – Steven Roose Oct 3 '17 at 12:53
  • 1
    Hello @StevenRoose : thanks for the reply. I've done it from bitcoin qt where there is an option to open configuration file from preferences tab. – RealSteel Oct 4 '17 at 4:08
  • Finally I found an answer using this comment here – RealSteel Oct 14 '17 at 9:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.