0

I got Mac Book Pro 2015 with Mac OS Sierra 10.12.6 (16G29) and 3 TB WD MyCloud network drive. I need to run bitcoin core client saving the blockchain data on this network drive, located on my home network. I created a symlink:

admins-MacBook-Pro:~ admin$ ln -s /Volumes/User/Bitcoin ~/Bitcoin

This worked fine, then tried to run the Bitcoin-qt client:

/Applications/Bitcoin-Qt.app/Contents/MacOS/Bitcoin-Qt -datadir=/Users/admin/Bitcoin/

But got this result: Bitcoin core is probably already running

Deleting the .lock file does not help. No files are created in the directory except the .lock file.

What is the reason and how to make it work?

Update: strange enough, but using the same machine on the same network, but different OS (Windows 10 via Bootcamp) the Bitcoin-Qt application works just fine with the data directory on the network drive. It started syncing.

4
+50

Core (more specific levelDB, the database library used) does not support network drives. Also, the UTXO access (chainstate) must be as fast as possible and should run on an internal drive, ideally an SSD.

If you need to reduce/transfer disk usage, there are two main possibilities:

Pruning

Add prune=550 to you bitcoin.conf (or startup with -prune=550) to reduce the kept block data to a minimum. Your node will still do full validation but does not server old historical blocks to other peers.

Symlinks

Symlink the blocks directory is possible. Check https://en.bitcoin.it/wiki/Data_directory#Transferability

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.