My Bitcoin full node worked in the past, but some time ago, it stopped synchronizing properly. The blockcount increases but stays far behind the blockchain:

% bitcoin-cli getblockcount                    

(The chain is at 493006 at the same time)

bitcoin-cli getpeerinfo shows that I have only two peers (I kept old results and, when it worked, it was several dozens of peers). Network seems OK on this machine, I can find no connectivity problem (tested with RIPE Atlas probes).

Log shows:

2017-11-04 06:58:01 UpdateTip: new best=000000000000000001605913d6d8dcf9ba337d613fc78a269f6c1ac0bc1a3e1e height=457868 version=0x20000002 log2_work=86.145812 tx=205962119 date='2017-03-18 20:33:31' progress=0.767130 cache=553.1MiB(4251353txo)
2017-11-04 06:58:58 UpdateTip: new best=000000000000000001be0ed9edf7d9bce998acf5019833624b929df320544df7 height=457869 version=0x20000002 log2_work=86.145846 tx=205963787 date='2017-03-18 20:46:52' progress=0.767136 cache=553.5MiB(4254813txo)
2017-11-04 06:59:21 UpdateTip: new best=0000000000000000024e01c470375adb787205320c094dccb5e5177b71381fab height=457870 version=0x20000002 log2_work=86.14588 tx=205965243 date='2017-03-18 20:49:17' progress=0.767141 cache=553.5MiB(4254630txo)
2017-11-04 06:59:32 UpdateTip: new best=0000000000000000017f1f8cc3a3adb4117563f4da24e0e8bf84eefc27689a87 height=457871 version=0x20000000 log2_work=86.145915 tx=205967793 date='2017-03-18 21:02:50' progress=0.767150 cache=553.8MiB(4256794txo)
2017-11-04 06:59:34 UpdateTip: new best=000000000000000000dddeee9c69bc6801414576d3d1f2f386077d72782f15f8 height=457872 version=0x20000000 log2_work=86.145949 tx=205968320 date='2017-03-18 21:07:23' progress=0.767152 cache=553.8MiB(4257262txo)

Version seems to be the latest one:

% bitcoind -version
Bitcoin Core Daemon version v0.15.0.0-g3751912e8e

Running on Ubuntu "xenial" (16.04)

  • Could you include more information about the machine you are running on? Include RAM and HD size, is it an SSD or spinning disk, what other programs are you running on it? How many hours per day is it connected and running?
    – Eric Allam
    Nov 4, 2017 at 7:05
  • The machine is dedicated to blockchain. It is a headless server with 4Gb of RAM and four Atom CPU @ 1.86GHz.
    – bortzmeyer
    Nov 4, 2017 at 7:12
  • What are the results of testing your connection here? Also have you followed all the steps in the Bitcoin core Network Configuration guide? bitnodes.21.co/#join-the-network
    – Eric Allam
    Nov 4, 2017 at 9:56
  • That is a very slow CPU, especially historical sync of the chain takes a lot of CPU time due to having a colder cache than syncing at the top (where transactions can be pre-validated).
    – Claris
    Nov 5, 2017 at 5:20
  • Running -debug bench will help you get an idea of how slow it is.
    – Claris
    Nov 5, 2017 at 5:21

1 Answer 1


OK, apparently, the problem was with the Ethereum daemon running on the same machine and that I had forgotten. top and free showed there was still CPU and RAM available but, when I stopped the Ethereum daemon, Bitcoin was able to get up to date. A bit strange.

% bitcoin-cli getblockcount 

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.