3

I bought some BTC a few years ago and they've sat in an old Bitcoin-qt wallet (0.8.5) on a USB drive ever since. I'm hoping to transfer them out into Coinbase or something similar, but none of my transactions seem to be entering the mempool. On the wallet, they appear as having left but have been stuck at 0 confirmations for over a week, but if I look the transaction ids up on blockchain.info (9def5314cd193eb375634fbbddb2ff07bb5db9710311b1afe4b0c531db949b57 and 10239862eb947b6194920045423ac1a1e75c8a9bb7bbd0e87b4c8676a2656457), it says they don't exist, which makes me think that they've not actually gone into the mempool.

The first transaction had no fee associated with it (don't hate on me - I've not actually sent any BTC before, and this was the default on my wallet), which is what I assumed the problem was. But when I tried again it should have had plenty to get confirmation quickly. I've tried using the getrawtransaction command from the console to get the hex and broadcast it using /pushtx: for the first transaction, it says the minimum relay fee wasn't met (fair enough), but for the second it returns "Missing parents for [txid #2 (with fee)] while inserting [txid #1 (without fee)]". This means very little to me. If I check my wallet address on blockchain.info it still has the original sum associated with it.

Apologies if this has been asked before (I have been looking for over a week and haven't found it if so!), but I'm at my wits end and could use some help. I'd be very happy to make a donation to anyone who can help me unlock my BTC as a token of my gratitude.

Thanks in advance!

  • 1
    Have you upgraded to using the latest version of Bitcoin Core? – Eric Allam Nov 4 '17 at 20:17
  • No, I was worried about the transactions getting stuck in limbo if I did that. I've also considered switching to Electrum or something similar, but haven't jumped ship for the same reason. I'd feel a lot better about it if I knew what the status of these transactions was. – ozer85 Nov 4 '17 at 20:49
1

There should be a file called wallet.dat. It contains your private keys which allow you to send your BTC.

Warning: Before you do anything with the file create at least one backup of it. Do not send, upload or otherwise share the file with anyone. Who ever has this file can spend you UTXO (steal your bitcoin).

Since the transactions both did not propaganda you can safely send them again. There are two ways you could approach this:


  1. Using a new version of bitcoin core
    • download and install bitcoin core v0.15.0.1
    • start Bitcoin-qt v0.15.0.1
    • let the blockchain sync (this might take a while)
    • stop Bitcoin-Qt, copy your old wallet.dat and replace the new wallet.dat in the bitcoin v0.15 directory, start Bitcoin-Qt
    • you should be able to send the transaction

  1. Using Electrum to sweep the private key(s)
    • download and install Electrum
    • create a new standard wallet and from a new seed
    • write. down. the. 12. words!
    • open your Bitcoin-qt v0.8.5
    • navigate to help > debug window > console
    • type dumpprivkey [your Address] (repeat multiple times if you have more than one Address)
    • copy the private key
    • in Electrum go to Wallet > Private keys > Sweep
    • paste you private key and click on sweep
    • Electrum sends the BTC to your Electrum wallet

Both methods should work for you. However since 2. is faster (no blockchain download needed) and you already considered switching to Electrum, this method might be preferred.

Edit: Don't delete the wallet.dat after you send your BTC. The private grants you access to the same amount of BCH (Bitcoin Cash). One BCH is at the moment worth 7-9% BTC or about $600.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.