0

I have built the bitcoin source code with a new pszTimestamp, hashGenesisBlock and hashMerkleRoot

The code builds fine and does not run into any assert problems when validating these hashes on [line 128 and line 129 of chainparams.cpp]. (Great)

However...

When I run bitcoin-qt I run into the error below:

Error: Incorrect or no genesis block found. Wrong datadir for network?

Potential Cause:

Is the reason I am encountering this error because I have not yet mined the genesis block? If so how do I do that? It seems that in the bitcoin code there is nothing about mining the genesis block. I have heard rumours that this functionality was removed and that I will have to download a separate program for this step. Please confirm.

  • I met same problem. I met CBlockDiskPos(nFile=0, nPos=8) error or AcceptBlock: high-hash, proof of work failed (code 16) error. Have you solved? Any updates? – creator Mar 1 '18 at 7:42
0

Thant is correct. You have to mine the genesis block first separately if you are compiling the most recent bitcoin codebase.

Checkout : https://github.com/vlamer/genesis-block-generator

  • Is it still work with newest litecoin source? (0.15.1) – creator Mar 1 '18 at 8:14
  • I'm not entirely sure of that but since its a complete copy of bitcoin source, I don't think anything would be different. – Laksh Gandikota Aug 14 '18 at 21:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.