0

I have installed the BitcoinABC client on my computer, and tried to set up the node, with no success.

This is how I run my server:

start bitcoind.exe --server=1 --rpcuser=user --rpcpassword=password --rest=1 --rpcport=8332 --datadir=F:\Bitcoin --help-debug --bind=10.1.0.4 

And this is the bitcoin-cli client:

start bitcoin-cli.exe --rpcuser=user --rpcpassword=password --rpcconnect=localhost --rpcport=8332 

The server runs, but displays nothing on the console, and the client closes immediately.

I have tried connecting from a remote machine, running on testnet (by adding --testnet=1 to the server), changing ports, starting the server with --reindex (after ~5 minutes there was still no output) etc.

I don't know what else to try, I'm already at the end of my wits.

I'm running on Windows Server 2012.

Edit:

I've made some changes:

start bitcoind.exe --server=1 --rpcuser=user --rpcpassword=password --rest=1 --rpcport=8332 --datadir=F:\Bitcoin --bind=10.1.0.4 --testnet=1

start bitcoin-cli.exe --rpcuser=user --rpcpassword=password --rpcconnect=localhost --rpcport=8332 getinfo

but the result is the same.

put on hold as off-topic by Andrew Chow 2 days ago

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions about cryptocurrencies or projects that are not Bitcoin, and are not applicable to Bitcoin, are off-topic. For more information, see this meta-discussion." – Andrew Chow
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Is bitcoind running? What is in debug.log? – Pieter Wuille Nov 15 '17 at 14:09
  • @PieterWuille It's running, and with the current setup (testnet), in debug.log the last few lines are: Pre-allocating up to position 0xe00000 in rev00040.dat, UpdateTip: new best=000000... – Eutherpy Nov 15 '17 at 14:12
  • @Eutherpy so if it's running, what is the problem? does bitcoin-cli report any error messages? – Janus Troelsen Nov 15 '17 at 14:27
  • Oh, the getinfo command no longer exists. Try getnodeinfo – Pieter Wuille Nov 15 '17 at 15:37
  • 1
    You should try without "start" , from a command line window . Or you can use a flag for CMD that makes it pause after execution of its child process – Janus Troelsen Nov 15 '17 at 22:05