My trezor worked fine until the other day it wouldn't connect. I tried myehterwallet, trezor app in Chrome, and the trezor.io site--nothing. I've tried using different cables, different computers, different usb ports and even followed the trezor instructions for emergency reset. Nothing is working to open my Trezor and allow access to my currency stored on it.

closed as off-topic by Highly Irregular, Pieter Wuille, Max Vernon, Andrew Chow Nov 22 '17 at 18:05

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions seeking help for restoring user accounts or other matters concerning your customer relationship with a company should be directed at the respective customer service. Please understand that we have no insights into such matters and therefore consider them as off-topic." – Highly Irregular, Max Vernon, Andrew Chow
If this question can be reworded to fit the rules in the help center, please edit the question.

  • I don't see any question. We can't help you fix broken hardware. – Pieter Wuille Nov 22 '17 at 1:58

You should have your Trezor recovery card with 24 words you have written down. With these 24 words (the recovery seed) you can access your coins without a Trezor. Here is an explanation.

If this doesn't help you might want to contact Trezor support.

Not the answer you're looking for? Browse other questions tagged or ask your own question.