1

I have just installed Debian 9 (my first linux OS), and I am now choosing my Desktop enviroment. I have doubts at choosing between GNOME and KDE.

I know that both are conpatible with BitcoinCore, but my concern comes from the UI differences. The KDE and Bitcoin Core UI are both runed by Qt and GNOME is runed by GTK.

Does this have any significance?

2

The particular desktop environment does not have a direct impact as long as you have the necessary libraries for running Qt applications.

On Debian (or Debian-Based distributions, such as Ubuntu) the following command should install the dependencies necessary for the UI:

sudo apt-get install libqt5gui5 libqt5core5a libqt5dbus5 qttools5-dev qttools5-dev-tools libprotobuf-dev protobuf-compiler

Those are the packages used by the bitcoin-qt package. Source

  • And which are those libraries? – Ander Aristondo Dec 4 '17 at 14:33
  • I have edited the answer to answer your question. However, most package management systems will handle installing dependencies for you. – Sergio Feo Dec 6 '17 at 23:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.