0

I have created a batch file and  I tried to run it. But when I click on the batch file to run it. But the command line window appears for a fraction of a second and then disappears.

cgminer.exe  --gekko-2pac-freq 200 -o stratum+tcp://peercoin.ecoining.com:3336 -u username.1 -p x

=========================================================== I have tried the below in a batch file,  it gives the below output in the command line

cgminer.exe  -o stratum+tcp://peercoin.ecoining.com:3336 -u username.1 -p x

cgminer version 4.10.0 - Started: [2017-12-24 04:09:20.602]

 (5s):528.0M (1m):507.5M (5m):516.4M (15m):366.6M (avg):516.0Mh/s
 A:0  R:0  HW:2  WU:5.6/m
 Connected to peercoin.ecoining.com diff 16.4K with stratum as user username

Block: c22a0a3f... Diff:1.61G Started: [04:15:53.420] Best share: 98

 [U]SB management [P]ool management [S]ettings [D]isplay options [Q]uit

0: AMU GS-10018: | 528.0M / 516.0Mh/s WU: 5.6/m

 [2017-12-24 04:09:16.557] Started cgminer 4.10.0
 [2017-12-24 04:09:19.601] Probing for an alive pool
 [2017-12-24 04:09:20.083] Pool 0 difficulty changed to 16384
 [2017-12-24 04:09:20.602] Network diff set to 1.61G
 [2017-12-24 04:15:53.420] Stratum from pool 0 detected new block at height 0

============================================================

Is the issue with the script for batch file?

The Syntax for the cgminer.

Run cgminer using following the commands below:

cgminer.exe --gekko-2pac-freq 200
-o stratum+tcp://solo.ckpool.org:3333
-u (your username here) -p (your password here)

Also how to verify the CGi miner is using the Gekko 2Pac BM1384 USB miner?

0

I had a similar problem when I first started with the 2pac. You didn't mention if you are using a Windows or Linux platform, but the solution is similar either way.

Solution: Ensure your CGMiner binary is compiled to support the Gekko 2Pac. It seems your BM1384 2Pac is not being recognized properly by CGMiner.

This output you provided:

"0: AMU GS-10018: | 528.0M / 516.0Mh/s WU: 5.6/m"

...shows that it is being enumerated as an "AMU" (which is usually ASICMINER block erupters ) It should be "GSC" for a GekkoScience device. That's also why you are seeing the low hash rate and hardware errors.

So, be sure you have a gekko-enabled CGMiner binary, and also ensure your batch file points to that same correct binary. (correct path)

If you need more detailed help, please state whether you are on a Windows or Linux platform.

  • I forgot to mention that the reason why, when you try to run cgminer with the --gekko-freq XXX option, it immediately fails, is because your cgminer is not compiled to support the gekko. (compiled with "--enable-gekko" When you run it without that option, it works, but it doesn't identify the 2Pac properly, and enumerates the device as "AMU" and doesn't hash properly. – DvG Dec 25 '17 at 19:59
  • Your batch commands to run cgminer look correct, no problems there. – DvG Dec 25 '17 at 20:08
  • Here is a link to cgminer with gekko that I'm using: github.com/vthoang/cgminer – DvG Dec 25 '17 at 20:25
  • Link to all things Gekko Science 2Pac: bitcointalk.org/index.php?topic=1764803.0 – DvG Dec 25 '17 at 20:32
  • Hey, The issue has been fixed. I'm using windows. I have downloaded a new version of cgminer for the fix. – Matt Dec 28 '17 at 6:04
0

for we linux (debian) geeks, you need to go to the directory you've done the compiling & all the dependancies. (that's a lot of stuff) when you configure the system, you start with root>: ./autogen.sh enable-gekko then after that is done ./configure enable-gekko then "make" all this stuff is in the cgminer.readme files I got it to work! In the past I only did the ./autogen.sh and the ./configure, just for giggles i added "make" to my procedure. Now the frequency command works. wheeee... who knows?

The command then is: ./cgminer -o stratum+tcp -u worker1 -p anything --gekko-2pac-freq 200

I've recently done a dist-upgrade to my OS, now the frequency paramater is not working. It is only displaying 3 of my 6 boards, and they are running +350mhz, not what a 150ghz chip is supposed to do. I'm digging more. Havent found the solution yet. I will post here when I do find it. FYI you must be using cgminer 4.1.0 shearch for that on GitHub. There are a couple forks, I've found no real difference. JLH

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.