0

Here's my bitcoin.conf:

server=1
rpcallowip=127.0.0.1
rpcuser=userrunningbitcoind
rpcpassword=passwordofuserrunningbitcoind
rpcport=7788
walletnotify=/home/userrunningbitcoind/transaction.sh %s

And here's my transaction.sh, which I've tried running manually already. This works without issue on its own:

#!/bin/sh
curl -d "txid=$1" http://127.0.0.1/api/process-payment

What else can I try to get walletnotify going?

EDIT:

I've additionally found this in my debug.log:

2018-01-19 05:49:22 Binding RPC on address 0.0.0.0 port 7788 failed.
2018-01-19 05:49:22 No rpcpassword set - using random cookie authentication
2018-01-19 05:49:22 Generated RPC authentication cookie /home/userrunningbitcoind/.bitcoin/.cookie
  • It should be working, note that it will only trigger for transaction to addresses in your wallet. Have you made a transaction ? To debug what is happening, you can see .bitcoin/debug.log – dark knight Jan 16 '18 at 11:22
  • @darkknight I've made transactions to attempt to test it. The debug log is enormous, and seems to be filled with unrelated messages. How would I filter it appropriately? – Fibericon Jan 16 '18 at 11:52
  • Search for transaction.sh in the log ...it should show up – dark knight Jan 16 '18 at 12:26
  • grep -i "transaction.sh" debug.log returned no lines. Is it possible that my bitcoin.conf is being ignored? – Fibericon Jan 16 '18 at 12:49
  • @Fibericon have you tried connecting to the RPC to see if the other settings have taken effect? – MeshCollider Jan 17 '18 at 12:57
0

Remember to restart bitcoind again after you make any change in bitcoin.conf file. It seems as if you set an rpcpassword in the conf but didnt restart the bitcoind service. You have everything set up properly i guess.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.