0

So, I have a website, and that website is going to use Bitcoins. Right now, I'm trying to connect the bitcoin core with the website.

But I have a lot of issues with port 8333:

This is my error: http://prntscr.com/i34pqa Bitcoin Config file: http://prntscr.com/i34q2e 8333 connections: http://prntscr.com/i34r1o

The bitcoin core I have is on a Linux VPS.

The thing is, I have to be able to connect the website to the bitcoin core, so I have this code in PHP:

include('c.bitcoin.php'); $bitcoin = new Bitcoin('root','MY PASS','MY VPS SERVER','8333'); $address = $bitcoin->getnewaddress('Test'); die($address);

That code works on Localhost, without using the VPS Server Just 127.0.0.1 which means it creates the address :), But when I'm trying to connect it to the bitcoin core that is on my VPS, it doesn't work.

I could open the bitcoin core if I change the rpcport on the bitcoin.conf to another port, like instead of using 8333, we are going to use 8332: http://prntscr.com/i34vni

And now, we check the node: http://prntscr.com/i34w5a It's supposed to be working :), But at the end of the day, it doesn't make a connection between my website and the bitcoin core on my VPS.

So I don't know what's going on. I don't know how to solve it, I've tried everything I've found on the internet, but nothing happens. I've written -listen=0, on the bitcoin conf, and I'm not able to connect my website to it yet,

I need this help, I need a big help, Thank you!.

  • And yes, My port 8333 is Open!. – Juan Jan 20 '18 at 16:24
2

You are conflating the two ports that Bitcoin Core opens and uses.

There is the Bitcoin network port. That is port 8333 by default. You DO NOT want to try to connect to that as it is used for the connection to other nodes on the network.

The port that you do care about is the rpcport. That is port 8332 by default. This is the port that you want to connect to as that is what lets you interface with Bitcoin Core.

If you don't set the port or rpcport options in the bitcoin.conf file, then the default ports will be used.


As a security measure, Bitcoin Core does not allow anyone to connect to the rpcport. You will need to explicitly allow an IP address to connect to it by using the rpcallowip=<ip> option in the bitcoin.conf file. If you set it to 0.0.0.0, it will be open to all IP addresses, but this is not recommended as it is not secure.


In your Qt settings, you have proxies enabled with port 8333. That's incorrect. Those are not the IP and port that you want Bitcoin Core to use but rather that a proxy is listening on those ports.

  • I tried to do it, even I added port and rpcport to the bitocoin config file, I changed rpcallowip = 0.0.0.0, but it doesn't work yet!. Same error!. Port 8333 doesn't want to flirt with Bitcoin core – Juan Jan 21 '18 at 2:05
  • 1
    The rpcport is 8332, not 8333. You need to make whatever you want to connect to Bitcoin Core connects to port 8332 not 8333. – Andrew Chow Jan 21 '18 at 3:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.