1

I tried to to host bitcoin core json-rpc to listen other than localhost but it would not work even i set it to listen to ip 0.0.0.0

My config (for bitcoin.conf)

testnet=1
server=1
daemon=1
listen=1
rpcuser=something
rpcpassword=secret
rpcport=8332
rpcconnect=0.0.0.0

So how do i make it so that it will listen to ip other than localhost or 127.0.0.1?

VPS informations:

Ubuntu 16.04

Latest Core (just installed it today)

client is remote

  • Some more details could help, such as operating system, where are you running the client, which version, etc. – Moritz Knüppel Jan 20 '18 at 17:54
  • Alright: Ubuntu 16.04 Latest Version (just installed it today) Client is over internet – zhiyan114 Jan 20 '18 at 18:11
2

The listen option is for the P2P network connection, not the RPC service.


The option you want is rpcallowip=<ip>. To allow all IP addresses to connect to your node's RPC port, you can use rpcallowip=0.0.0.0. Note that doing so is not recommended as it is insecure.


Don't set rpcconnect as that will make it impossible for bitcoin-cli to interact with Bitcoin Core.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.