0

I have sent and received a number of payments via the request function without problem. However, when I sent two payments directly from one bitcoin wallet address to another (from a business account to a personal account, public addresses), they are yet to arrive at the target! Is there an extra step I need to complete? I can't see that there is. Thank you D

Transaction IDs e9104412aac5327e5eaad31485335d822d5e7a22f00c370d8f055286ed02‌​e187 / 0e5fcac8b0618eabff747a0dea4cf4ff7dddf4b323e52f3473cd7581a88c425c

  • both tx are confirmed. Have a look at blockchain.info with your tx IDs, and see, if the target address matches the ones in your wallets. This is crucial. You didn't say which wallet you have/use, maybe the wallet first needs to synchronize with the network? – pebwindkraft Jan 24 '18 at 23:37
1

UPDATE: Payment/transaction didn't disappear. After looking into this it turns out the PASTED VALUE of e9104412aac5327e5eaad31485335d822d5e7a22f00c370d8f055286ed02‌​e187 has invisible ASCII characters in here. Looks like a color code or some conversion of the Byte array. The transaction IS valid, but copy/pasting from the question in this topic will result in invisible ASCII.

Example:

  • Bad: e9104412aac5327e5eaad31485335d822d5e7a22f00c370d8f055286ed02‌​e187
  • Clean: e9104412aac5327e5eaad31485335d822d5e7a22f00c370d8f055286ed02e187

They look the same, but they are not the same. You can test this by putting your cursor just after the final 'e' (4th to last character in string) then hitting the left arrow (be sure to use the "bad" or original example above). You have to hit the left arrow twice between the '2' and 'e'. The cursor is navigating the invisible character.

Here is a C# example of how to find this:

static void Main(string[] args)
        {
            var x = Encoding.Default.GetBytes("e9104412aac5327e5eaad31485335d822d5e7a22f00c370d8f055286ed02‌​e187");

            foreach (byte item in x)
            {
                Console.Write(item);
            }

            var a = Encoding.UTF8.GetString(x);
            var b = Encoding.ASCII.GetString(x);

            Console.WriteLine(a);
            Console.WriteLine(b);
        }

The result is:

1015749485252495097979953515055101531019797100514952565351515310056505010053101559750501024848995155481005610248535350565410110048506363101495655e9104412aac5327e5eaad31485335d822d5e7a22f00c370d8f055286ed02??e187

e9104412aac5327e5eaad31485335d822d5e7a22f00c370d8f055286ed02??e187

-------------------------END OF UPDATE-----------------------

It LOOKS like somehow the transaction ID is messed up. It's a transaction on the blockchain but at the same time it looks abnormal. All of these show and contain the transaction:

However, they "search" function in 2 of them fails to see it as a valid transaction (reported it to both). Was able to get to them by going to the wallet itself and finding the transaction. So while it is being consumed by looking at a raw block, the transaction ID itself is jacked up in some way.

This MAY mean, that your wallet program is also having a hard time seeing that transaction (even though it submitted the transaction to whatever node generated that transaction ID). It does exist and an expert should be able to form and submit a valid transaction to the blockchain using the UTXO's from it.

Without knowing more like what wallet is being used, the functionality of that wallet, in a general sense i would import that address into a more flexible more advanced wallet to see if it picks up the transaction. If it does, spend the UTXO's and stop using whatever wallet resulted in the malformed transaction ID. The node would have provided the transaction ID when it was submitted. So this is dependent on the wallet setup and what node setup the wallet used to cut out the "messed up" aspect.

Beyond that an expert in recovering this type of thing (assuming you still have ownership of it) should have no problem if you have access to the wallet and are willing to provide the information.

Note: This is not an endorsement of any particular recovery service (i listed none) or action you should or should not take. I've listed here some possible options to recover the coins from a wallet program that fails to see a particular transaction.

0

Are you sure you sent to the right address? I checked both your tx id and I can see the 2nd tx has been confirmed like you rightly said while the first tx couldn't be found on the blockchain. Here is what am thinking, if you sent correctly to the right address and the tx that couldn't be found on the blockchain is unconfirmed yet, it has dropped off from the node. So rebroadcasting it might help if it still doesn't show probably it's a double spend. but the confirmed tx id baffles me because I do not see any reason why it won't arrive at the destination address if you sent it right...

  • Thank you for your response. I have checked and checked the addresses. They are correct. I hadn't used my accounts for more than one year, if that makes any difference? The transactions took place pre-Xmas! How can I rebroadcast them, as you suggest? I assume the wallets are synchronized now as recent transactions have been successful. – M Oils Jan 25 '18 at 11:17
  • 1
    How can payments just disappear? This is maddening, and it seems that little to nothing can be done? D – M Oils Feb 13 '18 at 12:12
0

I tried to rebroadcast it for you with https://blockchain.info/pushtx, yet doesn't work and you not using your wallet for over one year doesn't affect the transaction in anyway. My confusion is, the tx id seems not to be genuine and yet you got a confirmation on one of the tx and the money still doesn't reflect. I honestly can't figure what the problem is, I will sure ask around and see if there is a solution, am really interested cus it might happen to anyone.

  • I also chose the budget transfer rate. Since these two failed transactions, I have selected the premium rate, which has always worked within minutes. Of course, even the budget option shouldn't take weeks! – M Oils Jan 26 '18 at 10:22
  • When I try to add the txs into blockchain.info/pushtx or blockchain.info/decode-tx I always get the following error "Parse: exception decoding Hex string: invalid characters encountered in Hex string" or "Parse: Error Parsing Transaction"! – M Oils Jan 26 '18 at 11:04
0

Your 2nd tx id works & can reflect a valid transaction. Your first transaction however doesn't seem to be a valid transaction id. More to the point as of this writing your 2nd tx has over 5000 confirmations. Assuming you've made these transactions in the order you listed them then the older transaction should have even more confirmations & listed in the blockchain. If you've made a transaction & it's failed to appear? I'd verify your complete address. (Not just the first / last few characters of the address as one wrong character being off can literally send your money into never never land to a wallet that may not even be being used at this point in time. You may wish to contact your sending wallet developer for assistance? Get some screen shots to show them what's up? Unfortunately you can't retransmit a transaction that's never happened. If it's not in the blockchain it's not real. If your wallet didn't sent it properly to the blockchain for processing that would explain why it never arrived. More to the point what kind of "security" is on your device that holds your wallet? Have you done a malware check ETC?

-2

I had the same problem. I couldn't understand where the payment went. I found out later that I made a mistake when entering the address. Check the payment details.

protected by Community Feb 27 at 5:25

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.