0

I have tried to installed zcoin insight ui & api in my local machine (ubuntu OS) and it is completed all the steps but I m facing issue while start services in frontground.

Let me share with you command, config file.

sudo apt-get install software-properties-common
sudo add-apt-repository ppa:bitcoin/bitcoin
sudo apt-get update
sudo apt-get install libdb4.8-dev libdb4.8++-dev
sudo apt-get install build-essential libtool autotools-dev automake pkg-config libssl-dev libevent-dev bsdmainutils
sudo apt-get install libboost-all-dev
sudo apt install libminiupnpc-dev
sudo apt-get install libzmq3-dev
sudo apt-get install libqrencode-dev
git clone https://github.com/zcoinofficial/zcoin.git
cd zcoin
./autogen.sh
./configure
make
cd src
./zcoind

But getting below error in my terminal:

   [2018-02-07T14:05:58.941Z] info: Starting bitcoin process
zcoind: zmq/zmqpublishnotifier.cpp:99: virtual void CZMQAbstractPublishNotifier::Shutdown(): Assertion `psocket' failed.
[2018-02-07T14:05:59.837Z] warn: Bitcoin process unexpectedly exited with code: null
[2018-02-07T14:05:59.837Z] warn: Restarting bitcoin child process in 5000ms
[2018-02-07T14:06:04.837Z] info: Using bitcoin config file: /home/zcoincore/bitcore-node-zcoin/zcoinnode/data/zcoin.conf
[2018-02-07T14:06:04.838Z] info: Starting bitcoin process
[2018-02-07T14:06:04.847Z] error: Failed to start services

MY Config File (zcash-bitcore-node.json)

    {
  "network": "testnet",
  "port": 3004,
  "services": [
    "bitcoind",
    "insight-api-zcoin",
    "insight-ui-zcoin",
    "web"
  ],
  "servicesConfig": {
    "bitcoind": {
      "spawn": {
        "datadir": "./data",
        "exec": "/home/zcoincore/zcoin/src/zcoind"
      }
    }
  }
}

Zcash Config (zcash.conf)

server=1
whitelist=127.0.0.1
txindex=1
addressindex=1
timestampindex=1
spentindex=1
zmqpubrawtx=tcp://127.0.0.1:28332
zmqpubhashblock=tcp://127.0.0.1:28332
rpcallowip=127.0.0.1
rpcuser=YANNISCOOLUSER
rpcpassword=YANNPASSISCOOL
uacomment=bitcore

Can you please help me with it? What is wrong in which step?

  • Your problem is with zmqpubrawtx zmqpubrawtx=tcp://127.0.0.1:28332 zmqpubhashblock=tcp://127.0.0.1:28332 Remove them and see if it will work. – Adam Feb 7 '18 at 15:52
  • Hello @Adam, Thanks for your feedback but it is getting below error after remove this 2 line from zcash.conf. error: Failed to start services error: Invalid state: "zmqpubrawtx" option is required to get event updates from bitcoind. Please add "zmqpubrawtx=tcp://127.0.0.1:<port>" to your configuration and restart – kiran malvi Feb 8 '18 at 4:56
  • 1
    Hello @Adam, Working fine after change 127.0.0.1 to MyserverIpAddress. – kiran malvi Feb 8 '18 at 5:12
  • Hello @Adam, In dash currency, I did same thing but it is returning error. Warning: Failed to create backup, file already exists! This could happen if you restarted wallet in less than 60 seconds. You can continue if you are ok with this. dashd: zmq/zmqpublishnotifier.cpp:101: virtual void CZMQAbstractPublishNotifier::Shutdown(): Assertion `psocket' failed. – kiran malvi Feb 8 '18 at 12:59
  • please add another question with more details – Adam Feb 8 '18 at 18:18
1

I solved this issue,

Actually it was issue related confliction because I have setup more than one currency in single server Like (Bitcoin, litecoin & zcash)

For that, I have taken care rpcport & change port for "zmq" in config file and then it is working fine.

Config:

server=1
whitelist=127.0.0.1
txindex=1
addressindex=1
timestampindex=1
spentindex=1
zmqpubrawtx=tcp://127.0.0.1:28334
zmqpubhashblock=tcp://127.0.0.1:28334
rpcport=8334
rpcallowip=127.0.0.1
rpcuser=YANNISCOOLUSER
rpcpassword=YANNPASSISCOOL
uacomment=bitcore
listen=0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.