0

Okay, I cloned a Dash source (learning)

Compiles fine on Linux/Win, I have peers and it was mining blocks fine during the initial launch. 200 Blocks mined, all peers sync'd up fine, sent Tx between one another. Everything works perfect.

I killed mining on it as there was no need for me to keep mining it (just learning) but I have found that since then, It will not sync, at all. Is constantly showing "catching up" What I have tried:

  • Rescan
  • Reindex
  • Tried a different machine
  • Let it sit for hours.

Nothing moves sync wise and it no longer will load any blocks after reindex (stays at zero). I figured it was related to no hashrate but I can't mine anything on it since the wallet isn't synced (i'm assuming). The error i get trying to mine is

json_rpc_call failed w/cpuminer 

setgenerate will only show 0 hash

1

Of course it isn't synced if you haven't mined blocks in a while. The assumption with networks similar to Bitcoin (and thus Dash) is that mining is constant so if a node sees that its most recent block is old, it will assume that it is not synced.

The RPC calls will check to see if you are synced and then only serve data to mining software if it is. You can just disable this check in the source code so that you can mine again.

0

My suggestion (I do not know about Dash specifically), if there are no new blocks for a timeout period the node thinks it is behind. This is certainly the case with some (non-Dash) clients.

  • Thanks for your response. Same rules apply here i believe. I just don't know how I'm supposed to mine a new block when it won't allow it. – Chris_Null Feb 17 '18 at 6:59
  • @sic_null Reset your time clock to just after the last block was mined. – Willtech Feb 23 '18 at 8:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.