1

have read all possible examples on the internet but still cannot connect to btc node from Java.

I'm using btcd-cli4j but have tried all other rpc libs as well, result is the same. This is the command:

BtcdClient client = new VerboseBtcdClientImpl(httpProvider, "127.0.0.1", 8332, "foo", "bar");  

This is the docker image:

version: '3.3'

services:

bitcoind:
image: seegno/bitcoind:latest
command:
  -printtoconsole
  -regtest=1
  -rest
  -rpcallowip=172.18.0.2
  -rpcuser=foo
  -rpcpassword=bar
  -rpcport=8332
  -server
  -logips
  -debug=rpc
ports:
  - 8332:8332

Have tried couple of different docker images as well. Always the same: Exception in thread "main"

HttpLayerException(super=CommunicationException 
(super=com.neemre.btcdcli4j.core.http.HttpLayerException: Error #1003001: The server responded with a non-OK (4xx) HTTP status code. Status line: HTTP/1.1 403 Forbidden, code=1003001))

My suspicion was around rpcallowip but don't know how to set correctly. This one is set by going into the docker container and executing hostanme -i to see the ip address. Setting that one in config and restarting the container.

  • I suspect that you are actually connecting to the RPC service since you are getting a 403 status returned and not a timeout. Does it work if you remove -rpcallowip=172.18.0.2? – Willtech Mar 17 '18 at 19:45
  • I would say that as well but cannot get a correct response. When removing it I'm getting Error #1004004: The operation failed due to an unknown IO exception. – Reeebuuk Mar 18 '18 at 9:30
2
+50

add or changed to

rpcallowip=0.0.0.0/0

this will fix most of rpc json 403 forbidden error (this has no security issues if your using it within your network)

  • I would have sworn I've tried this multiple times but heh, it is working now, that is all that matters :) – Reeebuuk Mar 18 '18 at 9:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.