0

So I made a mistake when I was new to Crypto. I used a Desktop Core wallet to store litecoin (17 of them). I somehow removed the program and deleted the wallet.dat file. The second I noticed I took the hard drive(s) out of the computer and reloaded windows on a new drive. I then made a sector for sector copy as a backup before attempting recovery. The main drive was a SSD and I had Windows 10 File History setup to back up to a HDD. After learning the basics of Python and figuring out the basics of PyWallet I was able to finally locate nearly 500 possible encrypted keys (I did not forget the password, I know for sure I have the correct password). I did try to simply replace the wallet.dat file with one of the recovered wallets (in appdata/roaming/litecoin folder) but none that I tried worked – Litecoin core would not open. Anyway. I ended up with about 550 wallet files from the recovery process (because file history saved a new version each day). So I did a full (non quick) format on a small 2GB jump drive and transfer all recovered wallet files (.dat) onto that jump drive with the assigned drive letter “L”. I create a folder on my C drive named “LCWALLET” I then run this in pywallet:

"pywallet.py --otherversion 48 --recover --recov_size=2Gio –-recov_device=L: --recov_outputdir=C:\LCWALLET"

I enter a password for the new wallet as prompted, and type the password for the recovered wallets. When I run this with all the wallet files on the jump drive it takes about 3 mins always results in this (ERROR): “Read 2.0 Go in 3.2 minutes Found 0 possible wallets Found 474 possible encrypted keys Found 0 possible unencrypted keys Traceback (most recent call last): File "C:\Python27\pywallet.py", line 4870, in recoveredKeys=recov(device, passes, size, 10240, options.recov_outputdir) File "C:\Python27\pywallet.py", line 1532, in recov list_of_possible_keys_per_master_key[tl[0][2]].append(ck) IndexError: list index out of range”

I know what this first step is only recording where to locate these keys but it does not extract or dump them – it does create a pywallet_partial_recovery_XXXDateTimeXXXX.dat file (this file too does not open in LC core). The next step if I did not get the python error would be to dump the keys. To do that I ATTEMPT to run this: pywallet.py --otherversion 48 --datadir=C:\LCWALLET --wallet=pywallet_partial_recovery_XXdatetime.dat --dumpwallet --passphrase=XXXMyPasswordXXX

I have run this with test wallets and it works so long as I don’t get the error on the first step, BUT with the error it does not work, here is what it returns: “ERROR:root:Couldn't open wallet.dat/main. Try quitting Bitcoin and running this again.” I am positive the permissions are set to 777 (everyone). I have tried renaming the partially recovered wallet, moving it to other locations and editing the command- NOTHING I do gets it past this. Next I try this whole thing again on a fresh full format jump drive (if I only do quick format then pywallet still finds the deleted wallets on the jump drive) so this time I only put 10 of the original recovered wallet.dat files. That returns zero wallets, and zero keys but no error. I can then move on to step 2 but there is no point since there is no private keys in that lot. Any of them that return possible encrypted keys toss up that error and won’t let me move on to step to.

Any help would be GREAYLY appreciated.

Screenshot: https://drive.google.com/file/d/1Yq0cF1w0apW8YI2eFvHtmAid0CYjQTHP/view?usp=sharing

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.