0

I have setup zcoin explorer in my server But it is not working 100%.

URL: http://159.89.175.64:3004/insight/

When you will check console, then you will get error in Blocks api. I have used

https://github.com/Technoprenerd/insight-api-zcoin

This github for api.

Let me share my config file: bitcore-node-zcoin.json

{
  "network": "testnet",
  "port": 3004,
  "services": [
    "bitcoind",
    "insight-api-zcoin",
    "insight-ui-zcoin",
    "web"
  ],
  "servicesConfig": {
    "bitcoind": {
      "spawn": {
        "datadir": "./data",
        "exec": "/home/zcoincore/zcoin/src/zcoind"
      }
    }
  }
}

zcoin.conf

server=1
whitelist=127.0.0.1
txindex=1
addressindex=1
timestampindex=1
spentindex=1
zmqpubhashtx=tcp://127.0.0.1:28334
zmqpubhashblock=tcp://159.89.175.64:28334
zmqpubrawtx=tcp://159.89.175.64:28334
rpcallowid=159.89.175.64
rpcport=8334
rpcuser=zcoin
rpcpassword=zcoin123
uacomment=bitcore
checklevel=2
listen=0


Stuck in belows url: 
http://159.89.175.64:3004/insight/blocks
http://159.89.175.64:3004/insight/address/TGu24MHgMNVNJ3xdPKTanXLd7KsU47ydar
http://159.89.175.64:3004/insight/tx/send (after send raw transaction).

Please let me know what I missed in the setup process.

Thanks in Advance.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.