2

I need bitcoind with enabled zmq. When I'm building bitocind from source and make ./configure the output is:

Options used to compile and link: ... with zmq = no ...

No matter what i pass to arguments.

My configure command looks like:

$ ./configure --enable-cxx --disable-shared --with-pic --without-gui --with-zmq --enable-zmq --prefix=/home/ubuntu/bitcoin/db4/

5

This will happen when you try to build with ZMQ support even though the required libraries are not on your system. In this case, configure will silently turn off ZMQ support, and you should see a line like

configure: WARNING: libzmq version 4.x or greater not found, disabling

in the output. When you install the required version of the ZMQ library on your distribution (make sure to pick the DEV version to get the header files as well), it should work.

  • Problem solved, thanks a lot. $ sudo apt install libzmq3-dev now zmq = yes – kickbit Apr 9 '18 at 13:09
  • For homebrew: $ brew install zeromq – chytrik May 7 '18 at 7:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.