0

I am installing bitcoin core. I cloned bitcoind source code from github. Before starting to install it, I already downloaded all dependencies by referencing on here. https://github.com/bitcoin/bitcoin/blob/master/doc/build-unix.md

$ git clone https://github.com/bitcoin/bitcoin.git
Cloning into 'bitcoin'...
remote: Counting objects: 113049, done.
remote: Compressing objects: 100% (3/3), done.
remote: Total 113049 (delta 2), reused 1 (delta 1), pack-reused 113045
Receiving objects: 100% (113049/113049), 101.22 MiB | 7.31 MiB/s, done.
Resolving deltas: 100% (78687/78687), done.
Checking connectivity... done.
$ cd bitcoin
$ git tag
...
v0.9.2rc2
v0.9.3
v0.9.3rc1
v0.9.3rc2
v0.9.4
v0.9.5
v0.9.5rc1
v0.9.5rc2
$ git checkout v0.9.5
Note: checking out 'v0.9.5'.

You are in 'detached HEAD' state. You can look around, make experimental
changes and commit them, and you can discard any commits you make in this
state without impacting any branches by performing another checkout.

If you want to create a new branch to retain commits you create, you may
do so (now or later) by using -b with the checkout command again. Example:

  git checkout -b <new-branch-name>

HEAD is now at b880967... Merge pull request #6169
$ git status
HEAD detached at v0.9.5
nothing to commit, working directory clean
$ ./autogen.sh
configure.ac:118: installing 'src/build-aux/compile'
configure.ac:12: installing 'src/build-aux/config.guess'
configure.ac:12: installing 'src/build-aux/config.sub'
configure.ac:37: installing 'src/build-aux/install-sh'
configure.ac:37: installing 'src/build-aux/missing'
configure.ac:707: warning: 'INCLUDES' is the old name for 'AM_CPPFLAGS' (or '*_CPPFLAGS')
configure.ac:707: warning: 'INCLUDES' is the old name for 'AM_CPPFLAGS' (or '*_CPPFLAGS')
src/Makefile.am: installing 'src/build-aux/depcomp'
configure.ac:707: warning: 'INCLUDES' is the old name for 'AM_CPPFLAGS' (or '*_CPPFLAGS')
configure.ac:707: warning: 'INCLUDES' is the old name for 'AM_CPPFLAGS' (or '*_CPPFLAGS')
parallel-tests: installing 'src/build-aux/test-driver'
configure.ac:707: warning: 'INCLUDES' is the old name for 'AM_CPPFLAGS' (or '*_CPPFLAGS')

I am going to install 0.9.5 release version. But what is this error ?

warning: 'INCLUDES' is the old name for 'AM_CPPFLAGS'

Even I ignored above warnings and executed make, but some errors occurred. If I execute autogen.sh on master branch, there is no error.

  • Why are you trying to build 0.9.5? That version is old and the build instructions and dependencies have changed since then. – Andrew Chow Apr 15 '18 at 17:53
  • I had a mistake. I confused that I saw over 0.10 versions as 0.1.0 versions. – xiaofo Apr 15 '18 at 19:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.