0

I run a synced litecoind on amazon ec2 linux instance.

[ec2-user@ip-xxx-xx-xx-xxx ~]$ litecoind -version
Litecoin Core Daemon version v0.13.2.1  

[ec2-user@ip-xxx-xx-xx-xxx ~]$ litecoin-cli getblockcount
1411130

I tried starting daemon with below commands

  • litecoind -testnet -daemon
  • litecoind -daemon , then litecoind -testnet

I want to get litecoin testnet address to test sending LTCT. But when I generate address i get litecoin address. How can I use this core to switch between main net and testnet ?

UPDATE

[ec2-user@ip-xxx-xx-xx-xxx ~]$ litecoind --testnet --daemon
Litecoin server starting
[ec2-user@ip-xxx-xx-xx-xxx ~]$ litecoin-cli getnewaddress
error: couldn't connect to server

top command shows litecoind running.
5787 ec2-user 20 0 786m 26m 288 S 1.0 2.6 0:00.63 litecoind

Is it okay if i kill the daemon ??

Please Help!

0
litecoind --testnet --daemon

Should be all you need to start in testnet and run as a daemon

  • How will I generate address ? litecoin-cli getnewaddress gave a "Lfq6zA5aTkRNPyBTUAPcevazpupvfkUXnK" – SMJ Apr 27 '18 at 12:29
  • How to check if this is LTCT address ? – SMJ Apr 27 '18 at 12:30
  • LTC testnet address should start with an n or m... so that is not a testnet LTC address – Fuzzybear Apr 27 '18 at 13:17
  • Can I generate testnet address with litecoin-cli getnewaddress command ? – SMJ Apr 27 '18 at 13:19
  • yup few instructions are here you might find useful coinpayments.net/help-testnet – Fuzzybear Apr 27 '18 at 13:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.