0

I am trying to do solo mining with bfgminer but it does not seems to be working

./bfgminer --url 127.0.0.1:18443 --user test --pass test

On bitcoind logs I can see the request logs

2018-05-14T10:36:25Z Received a POST request for / from 127.0.0.1:43312

2018-05-14T10:36:25Z ThreadRPCServer method=getwork user=test

2018-05-14T10:36:57Z Received a POST request for / from 127.0.0.1:43330

2018-05-14T10:36:57Z ThreadRPCServer method=getblocktemplate user=test

2018-05-14T10:36:57Z Received a POST request for / from 127.0.0.1:43332

2018-05-14T10:36:57Z ThreadRPCServer method=getwork user=test

On bfgMiner I can see the following messages

[2018-05-14 16:10:49] No servers were found that could be used to get work from.

[2018-05-14 16:10:49] Please check the details from the list below of the servers you have input

[2018-05-14 16:10:49] Most likely you have input the wrong URL, forgotten to add a port, or have not set up workers

[2018-05-14 16:10:17] Pool: 0 URL: http://127.0.0.1:18443 User: test Password: test

[2018-05-14 16:10:17] Pool: 1 URL: http://localhost:8332/#getcbaddr#allblocks User: test Password: test

Any help

1

The error messages you see are exactly what you get if you just start bitcoind without any proper configuration.

Did you make sure

  • you started your bitcoind with the -server flag at all? Only that will prepare your bitcoin node to allow connections from external workers such as bfgminer.
  • you waited for it to sync with the network? That can take up to some hours
  • This seems to be a good answer. However, please add some details, one-sentence answers are not well-received here. – MCCCS May 17 '18 at 15:43
0

first if your url is not on a mining server your not going to be able to mine (and probabalistically there may be a way but anyway). it would look closer to -o stratum+tcp://emc2.suprnova.cc:3366 and the 127.0.0.1 should be an API address not the url. second, for everyone who is looking for help with BFGMINER if you do not: export GPU_MAX_ALLOC_PERCENT=100 export GPU_USE_SYNC_OBJECTS=1

then it probabalistically will not work as well. The export commands sync bfgminer immediatly to my gpu: ASUS GTX 1080 and starts hashing around 900 k/hs.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.