1

I tried on a few different machines, vps etc. Also, few different altcoin litecoin included. Most were with 4 GB of ram, if this matters.

Every time when I enter the command getblocktemplate , I get return error message -7 "out of memory".

This prevents me from mining the coins in a pool.

Does anyone have any idea, why do I get these errors, and what to do to fix them?

1

It was the masternodes syncing. Once I created a masternode and synced it, the getblocktemplate started returning normally.

0

The error is exactly as it sounds: your machine was unable to allocate memory for the block template object thus it ran out of memory. You will need to use a machine that has more RAM.

  • 1
    I tried it ona a machine with 8GB of ram and still it returns the same error. Could it be, that the error indicates something else, or a blocktemplate could really take more than 8GB of space? – Alex Brest May 28 '18 at 19:01
  • The block template is really not that large. There's probably something else going on in your OS that is preventing it from being able to allocate the memory. – Andrew Chow May 28 '18 at 19:04
  • 1
    Any idea what could that be? Some file permissions? Any other ideas? – Alex Brest May 28 '18 at 19:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.