2

I am running Bitcoin Core Deamon version v0.16.0.0 on Ubuntu and need to call the getrawtransaction command for some TX.

To use the getrawtransaction I need to run bitcoin core with txindex=1. But if I am running with txindex=1 it says that I have to run the core with reindex or reindex-chainstate.

So I did run first bitcoind -reindex-chainstate and then bitcoind -txindex=1 and it still says that I have to run with reindex or reindex-chainstate. So I tried to run bitcoind -txindex=1 -reindex-chainstate but still says run it with reindex or reindex-chainstate. Now I am running bitcoind -txindex=1 -reindex

Is this the correct way? And is it normal that bitcoin-cli getblockcountis stuck on 0?

2

txindex=1 has to be added in the bitcoin.conf file.

When starting the node, the following command should be issued

bitcoind -reindex=1 -daemon

You can keep checking the debug.log file in the .bitcoin folder to see the progress of blockchain synchronisation

Until you have downloaded the entire blockchain and reindexed, getblockcount will keep returning 0.

  • Thank you for your answer. Is ist really necessary to add txindex=1in the bitcoin.conf file or is it also sufficient to run bitcoind with txindex=1 parameter? – Hans Dampf Jun 28 '18 at 10:29
  • adding it to conf file makes sure it will reindex everytime it syncs. In case you forgot to add the reindex option while starting bitcoind. – Shabahat M. Ayubi Jun 28 '18 at 12:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.