0

While installing dependencies for compiling an altcoin wallet on VPS for run a Masternode - using Ubuntu 16 I run into this fatal error

In file included from alert.h:9:0,
                 from alert.cpp:5:
serialize.h:19:48: fatal error: boost/type_traits/is_fundamental.hpp: No such file or directory
compilation terminated.
makefile.unix:200: recipe for target 'obj/alert.o' failed

whilst installing dependencies - the installation gets stuck on the last line - command not found

:~/Rupee-Core/src# libdb++-dev libboost-all-dev libcrypto++-dev libqrencode-dev libminiupnpc-dev
libdb++-dev: command not found
root@RUP2:~/Rupee-Core/src# libgmp-dev libgmp3-dev autoconf autogen automake libtool

does anybody have a suggestion what I could do to resolve this?

  • It almost looks as though boost is not installed and it's unable to continue compiling. Can you check that check it's installed using: sudo apt-get install libboost-all-dev and retrying? If not, perhaps it is an incorrect version of boost? I also don't understand the Rupee-Core/src lines, are you trying to run those packages? Have you tried installing those packages instead, like apt-get installing libdb++-dev libboost-all-dev ... etc ? If you haven't done that, I would try that first. – Owl Jul 12 '18 at 10:13
2

Not

libdb++-dev libboost-all-dev libcrypto++-dev libqrencode-dev libminiupnpc-dev

but

sudo apt-get install libdb++-dev libboost-all-dev libcrypto++-dev libqrencode-dev libminiupnpc-dev

Those are dependencies. install tells apt-get to download and install those dependencies. sudo gives apt-get admin permissions.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.