1

Trying to run the Main file of the wallet template from bitcoinj but JavaFX not found. When I run the main file of the wallettemplate I get multiple errors of javafx packages not found. When I try to run the entire thing I get an error missing a cucumber thing.

All the tutorials are outdated and I have only coded basic stuff.

Has anyone tried to use bitcoinj on intellij and java 10? Thank you.

1
  • yes, kindly post the logs
    – Zombie
    Aug 9, 2018 at 9:02

2 Answers 2

2

The JavaFX was removed from JDK > 8 of java.

Now reside is an open-source module of java, look at the official documentation.

Are available more plugins (maven and Gradle) for including the JavaFX in your project, look here

0

Install the JavaFX SDK

Check this

https://docs.oracle.com/javafx/2/installation/jfxpub-installation.htm

1
  • 1
    This answer is wrong, you have posted the the oracle documentation but the JavaFX jdk is no longer contained within. Now the JavaFX reside here for version > 9 of java Dec 5, 2019 at 14:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.