0

Is there an easy way to ensure that bitcoind restarts on system reboot? I tried placing the systemd service file in /etc/systemd/system but that didn't seem to work... thanks in advance

1
  • 1
    Try askubuntu.com if you're facing issues with the systemd script, it's not bitcoin specific, and those guys are a lot better at the whole linux side of things Aug 9, 2018 at 21:08

1 Answer 1

1

After putting the systemd file in /etc/systemd/system, make sure that your systemd file is set up to work with your installation (binary path, datadir path, etc. are correct). Then run sudo systemctl enable bitcoind.

Alternatively you can do edit your crontab with crontab -e and add the line

@reboot bitcoind
1
  • do you really need to put the executable in the system folder? Update path and add the root folder for the daemon so it can be updated easier and not forget to copy everything over...
    – GoZippy
    Aug 21, 2021 at 5:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.