1

Just started lnd for the first time connected to a bitcoind node. Do lncli getinfo and this is the error message. How can I get past this?

EDIT: Would like to add that I'm using lnd on testnet, however lncli is looking in the mainnet folder

0

Found the issue, lncli needed to be set to testnet and you need to create a wallet as well

lncli --network=testnet create
lncli --network=testnet getinfo
  • The answer should be more general. try mentioning the fact that one needs to provide a proper --rpcserver and --macaroonpath to match both lnd and lncli. For example: if lnd was started with: lnd --rpclisten=localhost:10003 --listen=localhost:10031 --restlisten=localhost:8003 --datadir=data then lncli should be started with: lncli --rpcserver=localhost:10003 --macaroonpath=data/chain/bitcoin/testnet/admin.macaroon supposing lnd was to be used with the testnet flag. The flags network=testnet or -n testnet are just a particular scenario of this. – ranchalp Nov 15 '18 at 9:59
0

After installation of the lnd for the first time you should initialize a wallet with a command: lncli create

Here is description of startup commands:

lncli help
...
Startup:
create          Initialize a wallet when starting lnd for the first time.
unlock          Unlock an encrypted wallet at startup.
changepassword  Change an encrypted wallet's password at startup.

It may require you to create the path:

mkdir -p <path from error message>
New contributor
Roman Shishkin is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.